Platform: GCP ✅

Other people have fixed similar problems by upgrading their accounts.

You can see if your account is “free trial” in the billing section.


Thanks! Will try that out and revert.

i didn’t mean new instance. I meant new conda environment which can be created by conda create -n NAME_OF_YOUR_ENVIRONMENT python=3.x.
After that,you can install tensorflow-gpu here.
You can follow this guide - pugetsystems
Hope this helps

Activate you environment you wish to show in kernels options, install ipykernel in it and do
python -m ipykernel install --user --name NAME-OF-ENV --display-name "ANYNAMe-HERE"

Just got my code/credit today. Thanks @czechcheck!!

I hope this will be a nice utility to help you get started with fastai on GCP.


Thanks @czechcheck for your $500 credit, applied in my account today. Now can work freely :grinning:

Thank you very much @czechcheck, I also got the $500 GCP credits. Amazing helping hand!

I solved this problem by upgrading my account

Hello! I’ve followed the steps indicated in the course page to configure the access from my PC to the jupyter notebooks stored in GCP.
How can I get the access to the jupyter notebooks from a different PC? Should I configure a new key?

Thanks for clarifying and the article.

Quoting from the article " You now have GPU accelerated TensorFlow 1.8, CUDA 9.0, cuDNN 7.1, Intel’s MKL libraries (that are linked into numpy) and TensorBoard. Nice!"

It is an article for CUDA 9.0 right?
What would you say to my previous point on " I don’t think i should be using this export IMAGE_FAMILY="pytorch-1-0-cu92-experimental" because it has CUDA 9.2 compiler which does not fit with tensorflow-gpu."

Meaning if i don’t create new instance, this my-fastai-instance is using CUDA 9.2 which does not easily install with tensorflow-gpu?

Thanks all for the support on this issue. I upgraded my account from Free to Paid and then I was able to create the boot disk according to the Guide given by Arunoda.

Now I am facing a different issue. When I SSH into the boot machine and try to run the Fast AI image command -

curl | bash

While installing I get the attached message and I am not able to do anything about it. I don’t know how to proceed with this as none of the keys work. Any help will be appreciated.

I’m not exactly sure about gcp, but in most cases yes, you just create another key. Ssh keys are supposed to be unique per machine.

1 Like

I just received my credits. Big thank you Petr :slight_smile:

Hmm. I am not really seen this issue.
I have further develop my workflow as a tool.

I have tried with GCP for many times, it works really well. This is using the official image.

I’m having a hard time starting my GCP vm instance !!
I already changed the zone. It worked for few days and now the same problem:
Error: The zone ‘projects/operating-land-216419/zones/us-central1-c’ does not have enough resources available to fulfill the request. Try a different zone, or try again later.
Looks like I’m not the only one. Any sugestion?

For the past couple of days I’ve also been unable to start my GCP instance, getting the error:

Error: The zone ‘projects/divine-outlet-218301/zones/us-west1-b’ does not have enough resources available to fulfill the request. Try a different zone, or try again later.

Other than that, I’ve found GCP to be much easier to use and considerably faster than other GPU enabled servers I’ve used.

@xtra_xtra_medium , You should not believe the error message “Try a different zone” , because I created a new vm from scratch on another zone and I got same error.

I just ran into this issue, too. I’d be fine with choosing <Ok>, but I can’t figure out how in the cloud terminal. Urgh.

Yes.How to choose OK…I am not able to figure that out.