Part 1 FAQ


#21

sure, you can. the easiest thing to do is to follow the paperspace setup script.


(Shubham Goyal) #22

Same here bro. Did the same mistake. Now I’m trying to setup AWS with Anaconda3, Cuda9 etc. I’ll update if I make any progress.


#23

I am in the position that nothing works. I go to paperspace, have a machine set up, but when I try to launch it now it never launches. I spend hours clicking on it and watching a little spinning wheel. There must be something better available to learn your course, could you point me toward it?
Also, the very few times I have been able to get the paperspace to launch, I am unable to open the jupyter notebook - the connection always times out.
I;m in the US, by the way - my wifi is pretty robust.
Is there another way to do this course? Any suggestions? Do I need to start over? Any help appreciated.


(Shubham Goyal) #24

Hey @jlrw, I just set everything for Course 1 V2(2018) on AWS using spot instances of p2. I guess I’ve got it running fine. Ping me if you’re stuck on setting up on AWS, maybe I can help. I chose to do this on AWS because I anyway use AWS at work for a lot of different purposes and it’s cheaper with spot instances.


(Dillon (Paperspace)) #25

Hi @jlrw Dillon here from Paperspace. Really sorry for the issues you are seeing that is definitely not a normal experience. Have you sent an email to support@paperspace.com by any chance? The terminal can get stuck sometimes but a browser tab refresh and closing the terminal window usually clears it up.


(Jeremy Howard (Admin)) #26

@dillon thanks for stepping in - perhaps once these student issues are resolved you could pop back here and let us know what you found, so that we can help each other better in the future without bothering you! :slight_smile:


(Fred Hersch) #27

I am getting the same problem. Any suggestions for how to fix this? I’m using google chrome.


(jsm) #28

My solution to stalled start-up on Paperspace

had the same problem but found a solution which seems to work on macOS 10.3
Chrome and Safari with firewall ON.

on the machines page on paperspace there is a icon to switch between icon and list view.
Switch to icon view.
click on selection box beside your machine
click on start button
wait for blue “ready” signal.
either ssh in, or click anywhere on that line to get a working terminal in browser.

hopefully this wasn’t just lucky. but this morning I got results.

good luck everyone else.


(Fred Hersch) #29

Thanks @jsm. I got a message back from paperspace that their machines were “full”, that it happens occasionally, and that additional space has now been added which should take care of the problem.


#31

hey there , new to the MOOC
I purchased a paperspace account and I have a question :
in the first lecture Jeremy says to test the model on our own images.
My question is , how do I download images to the “paperspace” computer ?
all I have is a shell command prompt. I can’t use a web browser to download new images.

thanks


#32

Hi @yaniv,

What I usually do in cases like this one is using the wget command and a Dropbox link.

  • wget is the command that you should use any time you want to retrieve content from a htttp of ftp link

  • I use Dropbox because it’s the easiest way: you can use any public link where you have stored your files. Google Drive doesn’t work that well in this case because it doesn’t give you a link with direct download, while Dropbox does. If you have Dropbox installed on your computer, put your pictures in a zipped archive, right click on the archive and the click on “copy Dropbox link”. At the end of the file you’ll have something like “?dl=0”, remove that part because it will make things easier later.

  • Once you have the archive in the folder you want: just unzip it (you may need to install the right command for it).


(Rohith Seelaboyina) #33

Hi,
I have tried to copy fastai library into google drive so that it can be used along with google’s colab GPU. https://medium.com/deep-learning-turkey/google-colab-free-gpu-tutorial-e113627b9f5d

However, when I run the cells in lesson1, I got following error.
Let me know how to resolve these errors.

ModuleNotFoundError Traceback (most recent call last)
in ()
----> 1 from fastai.imports import *

ModuleNotFoundError: No module named ‘fastai’


NOTE: If your import is failing due to a missing package, you can
manually install dependencies using either !pip or !apt.

To view examples of installing some common dependencies, click the
"Open Examples" button below.


(ramin pouyan) #34

Hi. I just started with the firat video but there is no way i can get to the terminal in order to download the configuration of fast.ai. How should I do it? thank you


(George Chase) #35

Just go to your shell and “curl http://files.fast.ai/setup/paperspace > fastai_script.sh”


#36

Hi, everyone.
I’m newbie here, and I have a question that which platform (Crestle, Paperspace, AWS) I should use.
I tried the first option of the lecture video, Crestle. But I found it much slower than the video – the lecture says it took 20 seconds to execute the example of lecture 1, but it took several minutes on the Crestle.
I don’t quite understand when watching the lecture, but what is the defference between Crestle, Paperspace, and AWS, and which one is recommended?
I am not so stingy, and don’t mind to pay for GPU server. But I don’t want to wait too much – I want my environment as fast as the lecture video.
thanks!


(Mathew Bordelon) #37

Setup question

Hey Guys!

I would like to get started on the course using my own laptop (instead of Paperspace), I am running Linux and have a NVIDIA GPU. Is the setup the same as if I was setting it up on Paperspace?

I.E instead of doing “curl http://files.fast.ai/setup/paperspace | bash” in the Paperspace terminal I can just do it on my own?

If not, is there any documentation that can walk me through the setup?

Thank you!


(Mathew Bordelon) #38

Wow! Should have looked deeper in the forums before asking!

If anyone has the same question in the future go here “How to do an Ubuntu local setup for part1 v2?


#39

You can use Google’s colaboratory platform for free. It comes with a Teskal K80 GPU too. So, give it a try.
Here is the link to set up colab:


#40

@jeremy
Thank you for great lecture on random forests. I have a question on selecting objective function for modeling.
On Kaggle and in various business settings, for regression problems various objective functions are used - RMSE , MAE , log-loss, Mean Absolute Percentage Error (MAPE) etc.

What is the right measure? What is the down side of choosing one over the other? Is selecting one of these a subjective business decision ? Looking forward to hear your thoughts.

Thank you,
Chandra


(Mira Ruder-Hook) #41

Hi @jeremy, I just set up my paperspace account and configured it to the course and had three questions about specific steps w regards to how to proceed. I referenced the GitHub page for the course, Reshamas materials, and the forum posts to try and figure out how my questions, but was not able to find the specific answer and was wondering if I could ask for some additional help?

I was trying to download Github data, set up a separate folder for my jupiter notebooks, and when to involve my local machine when downloading/completing the course.

  1. I am getting an error when I check for kaggle-cli on (fast ai) paperspace@… $ and I tried to install it using Reshamas step by step Github process, but I am getting the following error:
    I tried installing kaggle-cli too and still the message reads: '…requires path lib which is not installed…"

  2. How do we ‘clone’ fastai and save our notebooks in a different path like Reshamas has done?
    Here are her directions, but when I tried to update my .bashrc I was having trouble doing so.

Option 2: where you want
If you change the default location of your notebook, you’ll need to update your .bashrc file. Add in the path to where you’ve cloned the fastai GitHub repo:

for me, my notebooks are in a “projects” directory: ~/projects
my fastai repo is cloned at the root level, so it is here: ~/fastai
in the file .bashrc add this path:

export PYTHONPATH=$PYTHONPATH:~/fastai
Reminder: don’t forget to run (or source) your .bashrc file:

add path where fastai repo is to .bashrc
save and exit
source it: source ~/.bashrc

  1. For these steps (show below/throughout course), are we suppose to clone fastai on our local computer too or are these additional instructions for the paperspace GPU?

Normal installation
Download project: git clone https://github.com/fastai/fastai.git
Move into root folder: cd fastai
Set up Python environment: conda env update
Activate Python environment: conda activate fastai
If this fails, use instead: source activate fastai
Install as pip package

You can also install this library in the local environment using pip

pip install fastai

However this is not currently the recommended approach, since the library is being updated much more frequently than the pip release, fewer people are using and testing the pip version, and pip needs to compile many libraries from scratch (which can be slow).

Thank you!!