Part 1 FAQ

Does anybody know how to get free GPU service online (except at google colab)?

1 Like

Hey,
I am also facing the same problem. I created a entropay account and tried to pay through my debit card, when I try to pay I do get OTP on my phone but after entering the OTP and returning back to entropay interface I get error saying “We were unable to top up your Entropay card from this credit or debit card. Please check that your card details (including CVV and expiry) were entered correctly and that you have sufficient funds for this transaction on this credit or debit card.”
I do have sufficient funds in my account and I’ve checked all my credentials and they are correct.

Could you please help me in this regard? How did you pay for your entropay top up?

hi @jeremy. I was looking into the script that we get from setup for fastai. How did source activate fastai work as there was no environment called fastai got created before ?

You can run the fast.ai lessons on Kaggle Kernels, which now have free GPU support: https://medium.com/p/8ef4ca3b9ce6

Can someone help me to get free GPU? I tried google cloud, but there are no free GPUs. Also i tried google colab, even that is busy everytime and has less memory. Even i tried snark, but offer is over. Could anyone please help with the current available and good GPU ?

I would suggest taking a look at Kaggle Kernels

1 Like

Thanks @wdhorton for suggestions. After couple of tweaks, goggle colab helped me better. https://medium.com/@prakash_31206/fastest-way-to-setup-fast-ai-course-notebooks-for-free-using-google-colab-gpu-and-clouderizer-c8a004e1d50d

I’m having a problem in Paperspace disk space error. While I was downloading the data from Part2’s planet data, paperspace had a space error, so I tried to delete the big files that I’ve downloaded through jupyter notebook, but some weird error appeared and it won’t delete the file.

!

If I refresh the page, the file is deleted, but no matter what I delete, it keeps saying that there’s no space left in the device, so I can’t proceed anything.

Hello,

The google colab method worked for me but the colab instance is dying very quickly. The connection to the clouderizer machine is lost in under 10 min. I am wondering if this is related to my internet connection (around 30 Mbps) or something else.

If anyone else has solved this problem, I would appreciate help.

Thanks.

Hi all,

I set up an Ubuntu 18.04 system on my laptop (GTX 960M, yeah it’s not super powerful) and got everything running after having to build pyTorch from source to make it work with my older GPU. However, when I run the first training code in the Lesson 1 Notebook, I get this stack trace:

---------------------------------------------------------------------------
TypeError                                 Traceback (most recent call last)
<ipython-input-12-676345a6c308> in <module>()
      2 data = ImageClassifierData.from_paths(PATH, bs=8, tfms=tfms_from_model(arch, sz))
      3 learn = ConvLearner.pretrained(arch, data, precompute=True)
----> 4 learn.fit(0.01, 2)

~/fastai/fastai/learner.py in fit(self, lrs, n_cycle, wds, **kwargs)
    300         self.sched = None
    301         layer_opt = self.get_layer_opt(lrs, wds)
--> 302         return self.fit_gen(self.model, self.data, layer_opt, n_cycle, **kwargs)
    303 
    304     def warm_up(self, lr, wds=None):

~/fastai/fastai/learner.py in fit_gen(self, model, data, layer_opt, n_cycle, cycle_len, cycle_mult, cycle_save_name, best_save_name, use_clr, use_clr_beta, metrics, callbacks, use_wd_sched, norm_wds, wds_sched_mult, use_swa, swa_start, swa_eval_freq, **kwargs)
    247             metrics=metrics, callbacks=callbacks, reg_fn=self.reg_fn, clip=self.clip, fp16=self.fp16,
    248             swa_model=self.swa_model if use_swa else None, swa_start=swa_start,
--> 249             swa_eval_freq=swa_eval_freq, **kwargs)
    250 
    251     def get_layer_groups(self): return self.models.get_layer_groups()

~/fastai/fastai/model.py in fit(model, data, n_epochs, opt, crit, metrics, callbacks, stepper, swa_model, swa_start, swa_eval_freq, visualize, **kwargs)
    160 
    161         if not all_val:
--> 162             vals = validate(model_stepper, cur_data.val_dl, metrics, epoch, seq_first=seq_first, validate_skip = validate_skip)
    163             stop=False
    164             for cb in callbacks: stop = stop or cb.on_epoch_end(vals)

~/fastai/fastai/model.py in validate(stepper, dl, metrics, epoch, seq_first, validate_skip)
    240             loss.append(to_np(l))
    241             res.append([f(datafy(preds), datafy(y)) for f in metrics])
--> 242     return [np.average(loss, 0, weights=batch_cnts)] + list(np.average(np.stack(res), 0, weights=batch_cnts))
    243 
    244 def get_prediction(x):

~/anaconda3/envs/fastai/lib/python3.6/site-packages/numpy/lib/function_base.py in average(a, axis, weights, returned)
    381             wgt = wgt.swapaxes(-1, axis)
    382 
--> 383         scl = wgt.sum(axis=axis, dtype=result_dtype)
    384         if np.any(scl == 0.0):
    385             raise ZeroDivisionError(

~/anaconda3/envs/fastai/lib/python3.6/site-packages/numpy/core/_methods.py in _sum(a, axis, dtype, out, keepdims, initial)
     34 def _sum(a, axis=None, dtype=None, out=None, keepdims=False,
     35          initial=_NoValue):
---> 36     return umr_sum(a, axis, dtype, out, keepdims, initial)
     37 
     38 def _prod(a, axis=None, dtype=None, out=None, keepdims=False,

TypeError: No loop matching the specified signature and casting
was found for ufunc add

This seems to be an error in the fastai library, though I have no idea. I have looked extensively online for a solution to this problem to no avail.

Any help would be greatly appreciated!

Hi I just started learning Deep Learning. I am watching the lecture series and brought subscription plan for Paperspace. I followed every step as mentioned in the wiki and reached till the step of jupyter notebook. Then I started the file courses/dl1/lesson1.ipynb. However it is not complete, I just see the content till line torch.cuda.is_available() . After this there is no content as we saw in lecture. I am attaching the screenshot.

I also did git pull in the folder fastai, so my git repository is updated. But still I don’t know why I am not getting the full file.

Please help. Thanks in advance.

1 Like

FYI - they replied to me in three days.

I want use ide (such as pycharm, visual studio code) with jupyter notebook.

I saw Jeremy in his lecture could check function definition in ide from Jupyter. Can anyone tell me how to do that (set up)?

Thank you so much.

Hi. I have access to GPUs through the supercomputer in my university. Has anyone tried installing fastai material on a remote cluster ? Thank you.

watch lesson 1

after starting a paperspace machine and entering password the curl http://files.fast.ai/setup/paperspace | bash doesn’t work.
Am I missing anything?

  1. Tab -> get the list of Methods.
  2. shift + Tab -> Get the arugument list help.
  3. shift + Tab + Shift + Tab -> Documentation.
  4. shift + Tab + Shift + Tab + shift + Tab -> Documentation in a new window.
  5. ?learn.exp() --> result is similar to shift + Tab 3 times (4)
  6. ??learn.exp() --> Opens the source code
1 Like

I’m getting the same thing. This is my second time through, and first time running into this issue. Anyone else have thoughts on this?

The only way I could fix this was to copy everything over manually cell by cell from here:

I really hope all the notebooks aren’t broken.

Hi,
When having tutorial video for fastai v1 ?

2 Likes

Where can I find the video of lecture1 from Oct 22, 2018?