Nbdev_preview fails. property name execute is invalid

Hello all,

I’ve just created a new nbdev repo, I believe didn’t do anything special other than the end-to-end tutorial. However, when I ran nbdev_preview, I got this error:

ERROR: Project _quarto.yml validation failed.

In file _quarto.yml
(line 21, columns 3--10) property name execute is invalid
20:   description: "Dien-Hoa AI Blog"
21:   execute: 
22:     enabled: false
ℹ The error happened in location website:execute.

This is my repo: GitHub - dienhoa/dhblog: Dien-Hoa AI Blog

I’ve tried installing several quarto versions but always get the same error.

Does anyone know how to solve it, please?


You can remove that from _quarto.yml. The latest version of nbdev shouldn’t be adding that to the file.


I have a question for my nbdev project. When I run nbdev_docs:
“Error: reading metadata file from “/{project_lib}/sidebar.yml”
Error: Error: YAML file “/{project_lib}/sidebar.yml” not found”
I saw there is sidebar.yml but somehow the nbdev didn’t recognize that files. When I run nbdev_preview, there is another error comes up:
Error: TypeError: Error parsing args: serde_v8 error: ExpectedString.
Can you help me understand the problem and how to fix this? Thanks

pip uninstall nbdev
and then
pip install nbdev
and re-run the experiment works for me.