My laptop supports CUDA do I still need AWS set up?

Yeah, 4GB is fine. I have gtx 980’s as well, deeplearning still works fine.


I successfully followed the installation instructions up till theano.
On execution of git clone theano-0.8.2 --branch rel-0.8.2 , I am getting the
’git’ is not recognized as an internal or external command,
operable program or batch file.

It appears git is not installed. Please let me know from where I can get the git and where should I install it.


Hey Sunil,

You can get git here

1 Like


I believe @ that point in the guide you should have a mingw setup. press windows button -> type git bash , use this shell from now on. If you don’t have it elle_idan has linked it above.


I have been able to install theano. However after creating the system environment variables THEANO_FLAGS_CPU and
THEANO_FLAGS_GPU, on running
env | grep -i theano I find that the these variables are not shown on the git bash shell. Instead I am getting an output as

$ env | grep -i theano

Do we need to create THEANO_FLAGS sysenv variable as well in addition to the two I mentioned above and how to set this variable value?


Make sure you restart the shell after you export new system environment variables. I believe you can use both the export syntax from within the bash shell as well as my preference, which is to use the windows gui utility. I have pasted a copy of my environment variables in another thread: [Help] Alternatives to AWS and Microsoft Azure

Take a look at those and make sure they match up. Note the value for cnmem is debatable, you can get memory errors if its too high. For my 4gb cards I think I was running it around ~.65-70

Bottom line, those values should show up in your shell.


I am getting the following output on running $ python :

$ python
WARNING (theano.configdefaults): g++ not detected ! Theano will be unable to exe cute optimized C-implementations (for both CPU and GPU) and will default to Pyth on implementations. Performance will be severely degraded. To remove this warnin g, set Theano flags cxx to an empty string.
(‘blas.ldflags=’, ‘’)
numpy time: 0.328000[s], theano time: 0.344000[s] (times should be close when ru n on CPU!)
Result difference: 0.000000

It appears I missed something on the way in installing dependencies. Do I need to reinstall mingw?

Seems like it can’t find the g++ compiler. Look into installing msys, which goes with mingw. Using the mingw-get commands to accomplish this is the best way I think. I suggest you install mingw directly into the root directory. c:\mingw. Could also be an environment variable issue, I forget all the ones in play here, but I have a mingw home setup.

1 Like


Sorry for bothering you again. I have had some experience with MATLAB and Python but am new to complex things like
getting multiple dependancies right.

When I run THEANO_FLAGS = THEANO_FLAGS_CPU in the git bash some times it works while at other times I get the following error:

bash: THEANO_FLAGS: command not found

I tried exiting and restarting git bash as well. What is the issue?

Sorry, It was a syntax error. Running OK now.

1 Like


I installed Keras successfully. However on running the example python it looks like it is looking for tensorflow instead of theano. Is there any other example which calls theano instead of thensorflow ? The bash output is as follows:

$ python
Using TensorFlow backend.
Traceback (most recent call last):
** File “”, line 12, in **
** from keras.datasets import mnist**
** File “C:\Users\TAPASHETTI-SR\toolkits\anaconda2-4.2.0\lib\site-packages\keras-1.1.0-py2.7.egg\”, line 2, in **
** from . import backend**
** File “C:\Users\TAPASHETTI-SR\toolkits\anaconda2-4.2.0\lib\site-packages\keras-1.1.0-py2.7.egg\keras\”, line 64, in **
** from .tensorflow_backend import ***
** File “C:\Users\TAPASHETTI-SR\toolkits\anaconda2-4.2.0\lib\site-packages\keras-1.1.0-py2.7.egg\keras\backend\”, line 1, in **
** import tensorflow as tf**
ImportError: No module named tensorflow

I’ve found another technology stack that’s a bit more recent that works for:

Windows 10 / Visual Studio 2015 / Python 2.7 / Anaconda 4.2.0 / Cuda 8.0.44 / MinGW-w64 5.4.0 / Theano 0.8.2 / Keras 1.1.0 / OpenBlas 0.2.14 (optional) / cuDNN 5.1 (conditional for convolution neural networks) <- I mainly used these instructions, perhaps I will modify them to reflect a few of the idiosyncrasies I found. <-- this helped me solve a few problems with the first link.

Namely to modify %USERPROFILE%/.keras/keras.json so that keras uses theano instead of tensorflow:

“floatx”: “float32”,
“epsilon”: 1e-07,
“image_dim_ordering”: “th”,
“backend”: “theano”

I also had memory issues, we’ll see if that goes away when I get my own TitanXP on weds, muhahaha! To resolve the memory problems I had to pass new parameters to THEANO_FLAGS. The author has lib.cnmem=0.8, I had to lower mine to .7 or .65 to avoid crashing or slowdown.

My environment:

Somehow I matched the author’s speed results, his titan, vs my 980:

If anyone implements this and has questions feel free to ask, I think I have a decent working understanding now.

Now that I finally have my environment set and I understand a bit more python it’s time to re-watch the first lessons and implement!

Just grabbed my post from that other thread, yes I did notice that issue as well, then later noticed Jeremy actually mentions it in the video, but follow the instructions above to modify keras.json

The .json folder and the keras.json file within it must be created in c:/toolkits or in c:/toolkits/keras-1.1.0 ?

OK, got it. It is in ~.

Thanks a ton Shawn for all the support and answering all my questions patiently. I am through with the setup at last.

1 Like

Yeah, sorry I wasn’t more clear. Do note that %USERDATA% and ~ are the same thing in this instance.

Are there any additional steps in order to run the jupyter notebooks of the course ?

Not really, just go to the directory you want to run a notebook in, and type jupyter notebook. Doing this will start a browser session with jupyter. You can also use a plugin for pycharm and I think there is one for atom. You can issue the command jupyter notebook --no-browser to get a key, this is sometimes useful when you’re using an ide and just need the token. It seems to run the smoothest in it’s natural browser setting. Remember to start jupyter notebook through mingw, not cmd/powershell that way you can use ! commands for the bash shell. I also use the ‘dark reader’ chrome addon when using jupyter, cause it makes it look very pretty. :smiley:

1 Like

I am attempting Lesson 1 now. wget when issued through git bash returns
wget command not found. Is there anything I am missing?