Lesson 1 In-Class Discussion

(Bruce) #230

How to get Section folding in Jupyter Notebook? It’s working automatically on Crestle - I would love to have it on my local machine as well!


hi @jeremy, a bit confused here. Is the purpose of the teams so that we collaborate on a kaggle problem together or is it a way for us to learn and communicate amongst ourselves ?

I ask because when I’ve asked the other members of my team, they don’t seem to know either.

(Miguel Perez Michaus) #232

THANKS for that tip, Kevin, :+1:

I was also getting an error in Paperspace with that line, your solution seems to fix it.


Hinton has moved on and worked on the idea of Capsules and CapsNet for quite some years, and last week, his new paper was just out:

Dynamic Routing Between Capsules

(Chris Palmer) #234

Finally got to open the lessons on Crestle. However, it takes ages to load, and once I got to edit the lesson 1 notebook it was completely blank, and after a while I got the following message:

Error! error
Saving disabled
See console for more details

I wonder if anyone has this working?

(Gerardo Garcia) #235

I got it working earlier today and the service is awesome.
I think the guy needs to work on capacity planning for the service.
But of course that cost money.


The latest version, AlphaGo Zero, is RL on ResNet, current state of the art CNN


@anurag @jeremy Any update or plan to deal with the scalability and performance issue when all the students log in to Crestle? Should we try Paperspace instead?

(building render.com) #238

The issue is just with instance limits on the AWS account for Crestle, and I’m working with AWS to increase these limits. Hopefully by the next class!

(Chris Palmer) #239

Thanks for replying Gerardo :slight_smile:

So did you just start Jupyter, navigate through fastai2 into the dl2 directory, click on the check box next to the lesson1 notebook (there are a crestle specific version and a standard one), and then click the Edit or View button?

Clicking the Edit button I got that strange message after viewing a blank page for some while, clicking the View button just now I eventually got what looks like a running notebook, but when I run code I don’r see results.

How did you run this?


@anurag Thank you Anurag for the prompt reply and action. If you need help with site maintenance and support, please let us know.

(Nikhil B ) #241

@Chris_Palmer did you mean dl1 dir, or do you see a dl2? I’ve been using Crestle today, running smoothly. I had to git clone the new fastai repos locally. Navigating to the dl1 dir, and opening lesson1.ipynb should work.

@anurag Wonder if we can import code/data from git/other sources into our Crestle home dir?

(building render.com) #242

Yes, just use wget or git in the terminal after you start the notebook.

(Chris Palmer) #243

Sorry, I meant dl1.

I think my problem was that I didn’t know how to get the notebook running - I was on a slow connection (tethered to my cell phone on the train!) and I think that I was trying to Edit the notebook before it was even running, instead of letting it run and then interacting with it. Now that I am looking at it in a better situation everything seems to be working just fine :grinning:

Why did you need to git clone though? I just found all of the files already on my directory upon starting Jupyter.

(Chris Palmer) #244

Got it running now, I just had to be patient with it!

(Santhanam Elumalai) #245

It is from lesson 1 this line show’s below exception.
os : ubuntu 16.0

(Santhanam Elumalai) #246

Actually, I tried to access the folder. It is not available for ubuntu16.0.

(Jeff Lee) #247

Are you using crestle?

(Jeremy Howard (Admin)) #248

@santhanam as it says in the notebook, that section is only for crestle.

(Santhanam Elumalai) #249

Thanks Jeremy! It works fine now.