Kaggle Comp: Mercari Price Suggestion Challenge

Anyone interested in the Mercari Price Suggestion Challenge announced today? Interested in forming a team?


Note that it’s a kernels only competition so using fastai is not allowed unfortunately. I’ve tried reading and writing my predictions but it doesn’t work either. But maybe @jeremy might now a work around to enable our use of fastai for this competition.

I believe we just have to package fastai into a pip or conda package and then make a pull request to the kaggle kernel docker image. If someone wants to create a script/config to create the pip or conda package, I’d be most happy to run it!

Sure @groverpr @shik1470 and I would be very happy to do that. Thanks

I would love to participate also.

I really appreciate those sellers competitions.

1 Like

fastai should be available on pip now…


Nice job. Let’s move it into my pip account so I can maintain it. Also need to ensure it works with kaggle kernels docker image so we can send a PR there. Then we can use it in this comp!


I posted a message on the mercari competition “Official External Libraries Request Thread” asking for them to include it.


I am also interested in teaming up for this.

FastAI is now available in Kaggle kernels. My first attempt at getting the Rossmann Store Notebook running


Couple of issues.

  1. Some missing vars ‘Promo_fw’, ‘Promo_bw’, ‘StateHoliday_fw’, ‘StateHoliday_bw’, ‘SchoolHoliday_bw’
  2. Some missing cat_vars ‘AfterStateHoliday’, ‘BeforeStateHoliday’

Those are created in the notebook.

Unfortunately I’m not able to upload my fastai based solution to the Mercari kernel competition. I got a decent low 0.4 score but no use :expressionless: If I just do import torch as the first command even thats failing.

import torch 

---> 56 from torch._C import *      
58 __all__ += [name for name in dir(_C) ImportError: dlopen: cannot load any more object with static TLS

Yes I was trying to enter the Mercari Prices Suggestion with a a fastai based solution and it appears that pytorch is unusable in kaggle as both scripts and notebooks.Tried both

import torch and errors with below. Have sent email note to Kaggle, but no response so far

/opt/conda/lib/python3.6/site-packages/torch/init.py in ()
54 except ImportError:
55 pass
—> 56 from torch._C import *
58 all += [name for name in dir(_C)

ImportError: dlopen: cannot load any more object with static TLS

I am working on this competition with FastAI as well. Unfortunately, I’m getting this error. This was fixed in a later pull request. I believe that the fastai packages included by default in Kaggle are old and do have a fix for this (and possibly more) errors.

I started on the path of just including all the relevant raw code, but that just took me down a rabbit hole ending with me wasting a lot of time. Could I get some advice on how to get this fixed?