Issues with 'conda env update'

#1

Running on Paperspace.

My pip version is

pip 18.0 from /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/pip (python 3.6)

When I run this command

conda env update

I get error messages and it doesn’t seem to complete the update. Does anybody know how to resolve this?

Here is the output

(fastai) paperspace@pscovd6k1:~/fastai$ conda env update
Using Anaconda API: https://api.anaconda.org
Fetching package metadata …
Solving package specifications: .
Requirement already satisfied: torchvision>=0.1.9 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/torchvision-0.2.0-py3.6.egg (0.2.0)
Requirement already satisfied: opencv-python in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (3.4.0.12)
Requirement already satisfied: isoweek in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (1.3.3)
Collecting pandas_summary==0.0.5
Using cached https://files.pythonhosted.org/packages/97/55/ea54109a4e7a8e7342bdf23e9382c858224263d984b0d95610568e564f59/pandas_summary-0.0.5-py2.py3-none-any.whl
Requirement already satisfied: torchtext in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (0.2.1)
Requirement already satisfied: graphviz in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (0.8.2)
Requirement already satisfied: sklearn_pandas in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (1.6.0)
Requirement already satisfied: feather-format in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (0.4.0)
Requirement already satisfied: plotnine in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (0.3.0)
Requirement already satisfied: kaggle-cli in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (0.12.13)
Requirement already satisfied: ipywidgets in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (7.4.1)
Requirement already satisfied: numpy in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from torchvision>=0.1.9) (1.15.1)
Requirement already satisfied: pillow>=4.1.1 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from torchvision>=0.1.9) (5.2.0)
Requirement already satisfied: six in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from torchvision>=0.1.9) (1.11.0)
Requirement already satisfied: torch in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from torchvision>=0.1.9) (0.3.1.post2)
Requirement already satisfied: pandas in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from pandas_summary==0.0.5) (0.23.4)
Requirement already satisfied: tqdm in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from torchtext)(4.24.0)
Requirement already satisfied: requests in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from torchtext) (2.18.4)
Requirement already satisfied: scikit-learn>=0.15.0 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from sklearn_pandas) (0.19.1)
Requirement already satisfied: scipy>=0.14 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from sklearn_pandas) (1.1.0)
Requirement already satisfied: pyarrow>=0.4.0 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from feather-format) (0.8.0)
Requirement already satisfied: matplotlib>=2.1.0 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from plotnine) (2.2.3)
Requirement already satisfied: patsy>=0.4.1 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from plotnine) (0.5.0)
Requirement already satisfied: statsmodels>=0.8.0 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from plotnine) (0.9.0)
Requirement already satisfied: mizani>=0.4.1 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from plotnine) (0.4.4)
Requirement already satisfied: MechanicalSoup<0.9,>=0.7.0 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from kaggle-cli) (0.8.0)
Collecting lxml<4.1,>=4.0.0 (from kaggle-cli)
Using cached https://files.pythonhosted.org/packages/a0/b5/4c6995f8f259f0858f79460e6d277888f8498ce1c1a466dfbb24f06ba83f/lxml-4.0.0-cp36-cp36m-manylinux1_x86_64.whl
Requirement already satisfied: configparser in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from kaggle-cli) (3.5.0)
Requirement already satisfied: progressbar2<3.35,>=3.34.3 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from kaggle-cli) (3.34.3)
Requirement already satisfied: cliff<2.9,>=2.8.0 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from kaggle-cli) (2.8.0)
Requirement already satisfied: beautifulsoup4<4.7,>=4.6.0 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from kaggle-cli) (4.6.0)
Requirement already satisfied: cssselect<1.1,>=1.0.1 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages(from kaggle-cli) (1.0.3)
Requirement already satisfied: ipykernel>=4.5.1 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from ipywidgets) (4.9.0)
Requirement already satisfied: traitlets>=4.3.1 in /home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages (from ipywidgets) (4.3.2)
Exception:
Traceback (most recent call last):
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/pip/_internal/basecommand.py”, line 141, in main
status = self.run(options, args)
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/pip/_internal/commands/install.py”, line 299, in run
resolver.resolve(requirement_set)
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/pip/_internal/resolve.py”, line 102, in resolve
self._resolve_one(requirement_set, req)
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/pip/_internal/resolve.py”, line 261, in _resolve_one
check_dist_requires_python(dist)
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/pip/_internal/utils/packaging.py”, line 46, in check_dist_requires_python
feed_parser.feed(metadata)
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/email/feedparser.py”, line 175, in feed
self._input.push(data)
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/email/feedparser.py”, line 103, in push
self._partial.write(data)
TypeError: string argument expected, got ‘NoneType’

CondaValueError: pip returned an error.

1 Like

Conda env update error on Paperspace
#2

Same problem

0 Likes

(Gary Allison) #3

I’m having the same issue. Can’t get started with a new paperspace machine.

0 Likes

(Enrico Ballardini) #4

+1 Same here.

0 Likes

(Niko Gamulin) #5

Same problem here. I tried to install it on my Ubuntu 16.04 machine with conda 4.5.4 and pip 10.0.1

0 Likes

(Jeremy Howard (Admin)) #6

@dillon is this a paperspace problem? Could you please look in to it?

0 Likes

(Jeremy Howard (Admin)) #7

Does downgrading pip to version 10 help?

0 Likes

#8

I’m running into the possibly related issue mentioned here.

I tried downgrading by running fastai$ pip install pip==10.0.1 but received the same error:

pip._vendor.pkg_resources.RequirementParseError: Invalid requirement, parse error at "'; extra '"

0 Likes

#9

Getting the same error message as the original post even after downgrading to pip 10.0.0.

I decided to create another machine on paperspace. Things worked fine at first, but once I ran conda env update, I received the same error message posted here, and now I can’t even open jupyter notebook in that new machine

0 Likes

#10

I have the same error. Can someone help?

0 Likes

(Wayne Nixalo) #11

if @dillon’s issue is the same as what’s going around the forums right now, then I think there’s a hacky fix – my guess is jupyter_contrib_nbextensions is causing problems.

Fix:

  1. comment out the 4 jupyter lines in environment.yml
  2. run conda env update
  3. manually install the packages that weren’t installed (mkl-random, cython, etc)
  4. manually install the 4 jupyter packages that you commented out.

From this thread. Originally crashed into this issue trying to get things working on salamander in this thread.

0 Likes

Conda env update error on Ubuntu 16.04
FastAi installation problem
#12

I am using windows 10 laptop and have the same issue. “pip install” has parse error. “conda install” looks ok. Yesterday I set up another machine and that was successful.

0 Likes

#13

@Borz I just gave this a try and it didn’t work for me. Did you have to comment out the jupyter lines in environment-cpu.yml in addition to environment.yml?

0 Likes

#14

Alright, got it working with @Borz’s tip! I had to comment out one extra line:

# - jupyter
# - jupyter_client
# - jupyter_console
# - jupyter_core
# - conda-forge::jupyter_contrib_nbextensions

I commented these lines out in both environment-cpu.yml and environment.yml; not sure if doing it in both made any difference.

0 Likes

(Drew Marschner) #15

Same problem

0 Likes

(Jeremy Howard (Admin)) #16

I’ve commented out those lines for now, so a git pull should fix it.

1 Like

(Masaki Kozuki) #17

At this moment, the workaround is to comment out those lines. Is this correct?
Or specifying some older version e.g. 5.5.0?

This link is release notes of Jupyter.

0 Likes