How to set up Windows 10 for

(Andrea de Luca) #84

You have to make an hard link (mklink /d) that points from the notebooks directory to fastai library (or add fastai library directory to PYTHONPATH). But I advise to follow Jeremy’s new procedure from scratch. Look at the beginning of the thread, you’ll find a link!



i tried to create a link :

for lib, Library and libs to point to the environment fastai libraries but i still get the same error message.
Are these the right libraries?

(Andrea de Luca) #86


Suppose you cloned your fastai repository in C:\users\your_account.

Git has now created a new directory: C:\users\your_account\fastai.

The hard link target has to be: C:\users\your_account\fastai\fastai

Let us know!



Newbie here. I cannot find the environment-win.yml. I see environment.yml, environment-cpu.yml, and environment-old.yml.




environment-win.yml has been replaced with environment.yml recently

(McGeorge) #89

I followed the directions to a T.
In the fastai folder I typed:
conda env update
and got: conda not found

Its been years since I’ve used Unix but is this a path problem? Is there some .xxxrc file I need to edit and add directories to a path?

When I typed: jupyter notebook
I got the same error about jupyter not found

By following the steps listed under Optional Steps I did get jupyter notebook to work.

I can try : conda env update
when I next ssh into paperspace

(Ardhendu Pathak) #90

Thanks for this! “New Installation Instructions” also worked for me on MacOs for local cpu installation,
except environment-win.yml replaced by environment-cpu.yml



Today i have just managed to set up everything as per the instructions received on this link to set up the fast ai library and a python environment via conda.But i’m getting an issue wherein i have activated the new environment and from the kernel in the jupyter notebook,have selected the fast ai custom kernel.But i stll get an error saying that there is no module named fastAI.

Here are some pictures which can better describe the problem.


Hey everybody,

I can’t find an “environment-win.yml” file in the repo. I tried with the regular “environment.yml” file, but then jupyter notebook fails to import a bunch of libraries.

Anyone else have this problem? I’m running windows 10 and have an NVIDIA GeForce GTX 970 (although my assumption is still that it’s simply a problem with the environment setup).

Sorry if it’s an obvious mistake! I’m new to this!

Edit: I saw in the comments that “environment-win.yml” was replaced by “environment.yml”. So I guess my question is now: why are so many libraries missing when I try to import them in the jupyter notebook?


(Igor Kasianenko) #93

Check the step with creating symbolic link for fastai folder.
Looks like you need to start jupyter notebook from folder that contains symlink to fastai.

(Max) #94

I had the same issue and I solved it by creating a symbolic link for the fastai folder like this:
mklink /J E:\fastai\courses\ml1 E:\fastai\fastai
Where the first link is where you want to have the link: E:\fastai\courses\ml
The second link is the source: E:\fastai\fastai\

Earlier I had a problem with the installation.
conda env create -f environment.yml
always ended with: Command “python egg_info” failed with error code 1
When I tried to run the bulldozer notebook some modules where not installed. I had to manually install bcolz, cv2, graphviz, sklearn_pandas, isoweek, pandas summary, torch, torchvision and torchtext to get it working.
Anyone having a fix for my problem?

(Beverly Pena) #95

Thanks for sharing this topic, I’m a beginner here. Hope this will work for me. Thank you. Go2top Power ISO Crack.


I’m getting the following error.

(Zach) #97

@Amol1 were you able to resolve this problem? I am getting the same error.


I didn’t try after that. I started using clouderizer for the course.


I’m trying it again now. Clouderizer is too buggy.


I’m getting the following error when I try to manually install bcolz

(Zach) #101

Looks like you don’t have Microsoft visual studio installed


Installed Microsoft visual studio still getting the same error.

(Jeremy Howard (Admin)) split this topic #103

6 posts were merged into an existing topic: Howto: installation on Windows