Facing problem loading pretained architecture resnext101_64 while working with kaggle Kernels


(ashis) #1

Hello Guys,
Hope you all are doing good .
I’m facing problem loading pretrained architecture resnext101_64 while working in kaggle kernels . The code searches for weights at /opt/conda/lib/python3.6/site-packages/fastai-0.6-py3.6.egg/fastai/weights.
Its mentioned that the above location is read only , so I cannot push the downloaded weights to this location.
Anyone who has faced similar situation , I need some help.


(Imran) #2

AFAIK, you can’t use resnext with fastai in kaggle yet. Would need a code update.


(ashis) #3

I’m new to this fastai . what can I do something for that code update ? @imrandude


(ashis) #4

@z0k . did you come across this type of situation . I see that here How can I load a pretrained model on Kaggle using fastai? … Can you please suggest a suitable solution .


(ashis) #5

@z0k, I tried setting the path to current directory, but it didnt work out for me.


(mohamed amin houidi) #6

well that has nothing to do with resnext not working.you should give it the tmp and model paths to fix that:

TMP_PATH = “/tmp/tmp”
MODEL_PATH = “/tmp/model/”

then in convlearner,pass them as tmp and model paths:

learn = ConvLearner.pretrained(arch, data, precompute=True, tmp_name=TMP_PATH, models_name=MODEL_PATH)

but the resnext101 won’t work on kaggle,don’t know why.just use another structure.