Download_url error

I don’t know to fix it, help me plz.


having the same problem

Hi Hao

Does this help (Untar_data() help)

Regards Conwyn

I use azure search and I want to download url then this error occurs.

got the same error just running the official fastbook chapter 2 colab…


from import *

at the the top of your notebook.

thx but still not working

Consider using an alternate image scraper (jmd_imagescraper). It uses Duck Duck Go to search (which in turn relies on Bing I believe). Only will need to replace a few lines in the notebook. Detailed description here:

I ran into the same problem. It seems that in the latest fastai package version 2.5.0 the method download_url() has been entirely removed (it used to live in When you run the Gradient server for example and update the packages as the instructions say you pull this new version.

The method is available in the version just before, 2.4.1. If you open a terminal in your notebook server and run pip install --upgrade fastai==2.4.1 it will give you the previous version and this method will work.

If possible, would be great for someone to update the docs so that users install a version of fastai that is compatible with the fastbook course notebooks cc @jeremy


@kilgoretrout It works! Thank you so much. :relieved:

Looks like download_url exists in fastdownload.
from fastdownload import download_url worked for me.


This solved my problem perfectly. Thank you.

1 Like

Sometime downlod link are not working.

Sometime downlod link are not working.
download_url ( )