Lesson 1 In-Class Discussion


#331

Hi, KevinB, I come across the same problem “RuntimeError: CUDNN_STATUS_INTERNAL_ERROR”, how did you solve this? Thanks!


(Kevin Bird) #332

Try deleting your tmp folder. You will need to rerun everything at that point. If I remember correctly, that solved it for me, but I may not…


(Gavin) #333

PaperSpace Setup Problems.

I am having difficulty with the PaperSpace setup. I have followed the setup up on 2 machines which encountered a problem at the same point, but manifested different problems.

On both occasions the install “froze” at the “???-seaborne-???” install step. It reached 100% and the nothing happened. No cursor, no command prompt, nothing. If I leave it eventually the machine goes to sleep and I have to go back to the console and launch the machine again. Refreshing the browser does nothing.
If I install this via a terminal the terminal disconnects with a “broken pipe” error. I also noted it didnt have a data directory installed
If I try and redo the install it fails as it cannot find a directory to remove /etc/???confi.d something or another. Even through I can navigate to it manually.
My only option was the delete the machine and start again.

Created a new machine which got stuck at the same point. Left it alone until it eventually went to sleep. Went back to console and relaunched, this time the data directory was there.
Tried to git pull from root but it didnt recognise the command. Navigated to fastai dir and git pull worked ok.
Tried the update conda and it didnt recognise the command. Navigated to several locations and no luck.
Now the machine has gone to sleep and I had to go the the console and go to machine actions menu to restart.
Either the restart is super slow or doesnt work. Just got a cursor with no command prompt.

Anyone else encounter this? Just noticed I’ve now lost the cursor - the in browser terminal is just blank.

Dont have this issue with AWS…


#334

I met the same problem while running the following codes.

data = ImageClassifierData.from_paths(PATH, tfms=tfms_from_model(resnet34, sz))
learn = ConvLearner.pretrained(resnet34, data, precompute=True)
learn.fit(0.01, 3)

I did the follow steps and it was fixed.

  1. restart the VM
  2. reinstall all necessary libraries
  3. install Pillow 5.0.0 by pip3 install pillow==5.0.0.

Maybe you should try installing Pillow 5.0.0 first.


(pratima) #335


I have changed the batch size from default to 4, 8, 16 but I am still facing the same problem.
How do I fix it. Please suggest