Gunicorn and Nginx Configuration Settings


(Sritanu Chakraborty) #1

I am doing some X-Ray image classification task. However, I am having trouble setting up the nginx and gunicorn configuration. I have a paperspace P4000 machine where I would like to have the webapp live.

I have to admit I am pretty much new to setting up nginx and gunicorn servers.

My hello.py file:

from flask import Flask

app = Flask(__name__)

@app.route('/')
def index():
	return 'Hello There!!!'

if __name__ == "__main__":
	app.run(host="0.0.0.0")

My /etc/nginx/sites-available/flask-settings is :

    server	{
             location / {
                   proxy_pass http://127.0.0.1:8000;
                   proxy_set_header Host $host;
                   proxy_set_header X-Real-IP $remote_addr;	
    }

}

And I am using app.run(host=‘0.0.0.0’) in my hello.py. Right now, it’s just a simple hello world file but I would like to get the server set up right first as the DL model and code are already done.

The output of gunicorn hello:app -b 0.0.0.0:8000 :

   [2257] [INFO] Starting gunicorn 19.9.0
   [2257] [INFO] Listening at: http://0.0.0.0:8000 (2257)
   [2257] [INFO] Using worker: sync
   [INFO] Booting worker with pid: 2260

My /etc/nginx/nginx.conf:

user www-data;
worker_processes auto;
pid /run/nginx.pid;

events {
	worker_connections 768;
	# multi_accept on;
}

http {

	##
	# Basic Settings
	##

	sendfile on;
	tcp_nopush on;
	tcp_nodelay on;
	keepalive_timeout 65;
	types_hash_max_size 2048;
	# server_tokens off;

	# server_names_hash_bucket_size 64;
	# server_name_in_redirect off;

	include /etc/nginx/mime.types;
	default_type application/octet-stream;

	##
	# SSL Settings
	##

	ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
	ssl_prefer_server_ciphers on;

	##
	# Logging Settings
	##

	access_log /var/log/nginx/access.log;
	error_log /var/log/nginx/error.log;

	##
	# Gzip Settings
	##

	gzip on;
	gzip_disable "msie6";

	# gzip_vary on;
	# gzip_proxied any;
	# gzip_comp_level 6;
	# gzip_buffers 16 8k;
	# gzip_http_version 1.1;
	# gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

	##
	# Virtual Host Configs
	##

	include /etc/nginx/conf.d/*.conf;
	include /etc/nginx/sites-enabled/*;
}


#mail {
#	# See sample authentication script at:
#	# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#	# auth_http localhost/auth.php;
#	# pop3_capabilities "TOP" "USER";
#	# imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#	server {
#		listen     localhost:110;
#		protocol   pop3;
#		proxy      on;
#	}
# 
#	server {
#		listen     localhost:143;
#		protocol   imap;
#		proxy      on;
#	}
#}

The paperspace machine ip is 184.105.5.164 . But whenever I trying to access that it’s timing out after some time.

Looking forward to suggestions.

UPDATE : I had to open the port using sudo ufw allow [PORT] . It worked.