AWS AMI available for testing


(Abi Komma) #125

Thanks for the suggestion. Will pursue the AWS DL AMI route.


(arunabh) #126

@jeremy I created an instance with your AMI. but nothing is installed when i run lesson 1. cuda, torch and bcolz keep showing import error.

please advise, it has taken me forever to finish fast.ai lesson 1 due to this issue


(Gokkul Nath T S) #127

@arunabh Spin up a instance with plain Ubuntu 16.04 and Try Running the paperspace bash script here . If you get any error in the inital few lines comment/remove them. It will work fine i suppose.


(arunabh) #128

thanks. will try


(arunabh) #129

Still does not work. torch not found is an error that pops up again and again. Also, a lot of python libraries are not installed when running the jupyter notebook


(Gokkul Nath T S) #130

can you post what error you have got ? Did you run the script by SSH into the Instance using putty like softwares: Web GUI slogs. if you still face the problem.
Try the following:

  1. If you have got the Cuda drivers and CUDNN and anaconda Setup. Else run the commands from the paperspace script line by line.
  2. Do a git clone on Fastai repo. Delete Fastai Environment if present using : conda env remove -n fastai
  3. Create a new environment using the environment.yml present in the fastai repo.
    Hope it helps.
    ~Gokkul

(Rajesh) #131

May I know how this was solved? @arunabh
Have the same kind of problem. Though with bcolz.


(Pierre Guillou) #132

Hi everyone, my post that solves the question “how to setup fastai in an Amazon AWS region without fastai AMI like in Europe”.