Why Does Conda Want to Downgrade Fastai?

(jl303) #1

I’m on Google Cloud Platform.
I followed the instruction on how to setup GCP.
I installed Fastai using the command “sudo /opt/anaconda3/bin/conda install -c fastai fastai”. Everything worked fine.
Now I tried to update by using this command “sudo /opt/anaconda3/bin/conda update -c fastai fastai”.
Now it wants to downgrade fastai 1.0.52-1 --> 1.0.34-py_1. How can I upgrading instead of downgrading?
Here’s the full log.
Thanks!
Collecting package metadata: done
Solving environment: /
The environment is inconsistent, please check the package plan carefully
The following packages are causing the inconsistency:

  • fastai/noarch::fastai==1.0.52=1 done

Package Plan

environment location: /opt/anaconda3

added / updated specs:
- fastai

The following packages will be downloaded:

package                    |            build
---------------------------|-----------------
fastai-1.0.34              |             py_1         110 KB  fastai
mkl-2018.0.3               |                1       198.7 MB
mkl-service-1.1.2          |   py37h90e4bf4_5          11 KB
mkl_fft-1.0.6              |   py37h7dd41cf_0         150 KB
mkl_random-1.0.1           |   py37h4414c95_1         372 KB
numexpr-2.6.8              |   py37hd89afb7_0         190 KB
numpy-1.15.4               |   py37h1d66e8a_0          35 KB
numpy-base-1.15.4          |   py37h81de0dd_0         4.2 MB
regex-2018.08.29           |   py37h7b6447c_0         348 KB
scikit-learn-0.20.1        |   py37h4989274_0         5.7 MB
scipy-1.1.0                |   py37hfa4b5c9_1        17.9 MB
spacy-2.0.16               |   py37h962f231_0        47.4 MB
thinc-6.12.0               |   py37h4989274_0         1.6 MB
------------------------------------------------------------
                                       Total:       276.7 MB

The following NEW packages will be INSTALLED:

msgpack-numpy pkgs/main/linux-64::msgpack-numpy-0.4.3.2-py37_0
plac pkgs/main/linux-64::plac-0.9.6-py37_0
regex pkgs/main/linux-64::regex-2018.08.29-py37h7b6447c_0
spacy pkgs/main/linux-64::spacy-2.0.16-py37h962f231_0
thinc pkgs/main/linux-64::thinc-6.12.0-py37h4989274_0
typing pkgs/main/linux-64::typing-3.6.4-py37_0

The following packages will be DOWNGRADED:

anaconda 2019.03-py37_0 --> custom-py37_0
fastai 1.0.52-1 --> 1.0.34-py_1
mkl 2019.3-199 --> 2018.0.3-1
mkl-service 1.1.2-py37he904b0f_5 --> 1.1.2-py37h90e4bf4_5
mkl_fft 1.0.10-py37ha843d7b_0 --> 1.0.6-py37h7dd41cf_0
mkl_random 1.0.2-py37hd81dba3_0 --> 1.0.1-py37h4414c95_1
numexpr 2.6.9-py37h9e4a6bb_0 --> 2.6.8-py37hd89afb7_0
numpy 1.16.2-py37h7e9f1db_0 --> 1.15.4-py37h1d66e8a_0
numpy-base 1.16.2-py37hde5b4d6_0 --> 1.15.4-py37h81de0dd_0
scikit-learn 0.20.3-py37hd81dba3_0 --> 0.20.1-py37h4989274_0
scipy 1.2.1-py37h7c811a0_0 --> 1.1.0-py37hfa4b5c9_1
wrapt 1.11.1-py37h7b6447c_0 --> 1.10.11-py37h14c3975_2

0 Likes

(Patrick Trampert) #2

Updating with conda does not work:

In order to update your environment, simply install fastai in exactly the same way you did the initial installation.

See also

0 Likes

(jl303) #3

Thanks! The command from Github “conda install -c pytorch -c fastai fastai” worked. It doesn’t complain nor downgrade. I guess there’s no update.

0 Likes