Uploaded notebook does not appear in my Blog

Hello Fastai community,

I just build my Blog with Fastpages. I tried to add new blog post, so I uploaded a notebook respecting the rule of : YYYY-MM-DD-*.ipynb (2022-07-30-LessonOne.ipynb)

but still nothing changed in the blog?!

Any idea why, or how to fix it?

I think that’s because in the timezone that GitHub is in, it’s not 2002-07-30 yet.

1 Like

Thank you Jeremy, make sense :sweat_smile:
I will re-upload the notebook with proper date accordingly to GitHub timezone.

Did a lot of tweaking to solve this but I still can’t see all uploaded files in my blog.
For notebooks I find out that only those with images didn’t appear in the blog.
For .md file, the image do not appear (it looks like this)
Screenshot 2022-07-31 at 02-04-00 https __ismaai008l.github.io
but I can see the file and read it, also weird thing: to upload a .md file the description and extended description must be added while committing the upload of the file!!

I never do any version control or work with GitHub, so I may be missing something basic
anyway I will try to find some Fastai student who write many notebooks and see his/her repo and try to learn from it.

Could it be that the images aren’t committed and pushed to GitHub? Do they appear in the GitHub file browser?

1 Like

Yes they appear normally when I open the notebook from GitHub browser.

I just uploaded a notebook ( with no image in it) successfully and I can see it and open it on my Blog, then I tried to re-upload it with other name and added a cell with an image, it did upload on GitHub but didn’t appear in my Blog.

Just in case you have 5 min or less you can see what I missed by visiting my repo/Blog:

appreciate your comment Wasim

1 Like

Try putting output_47_2.png in the images directory that’s already in the root of your project. Then change the link to ![output_47_2.png](/images/output_47_2.png)

1 Like