When I run the new notebook I get latest notebook for tomorrow’s class. For the untar_data line I get “NameError: name ‘untar_data’ is not defined” It is not loading from fastai.datasets. How is this to be addressed?

I fixed that by reinstalling fastai. The new version of fastai fixed the problem.

for my case, I needed to remove pytorch and pytorch-vision and made a whole new install.

best wishes

won’t just installing fastai agin work. Why will pytorch n py-vision affect this

you can try first updating fastai and see if things work well with you… for my scenario I had to redo the whole thing. Note that, I was using Salamander.ai cloud service (which is an awesome service by the way).

please try to update fastai first and report your findings so people would not just follow my info and redo a whole new install for no valid reason.

I am also using Salamander.ai . I was unaware you could uninstall pytorch on that. Ok will try

I created a new environment in using the terminal, and I installed everything from scratch (python 3.6, pytorch, pytorch vision and fastai v1).

and I made a new folder and cloned the v3 course material in it.

you can easily access the terminal from jupyter notebook using New >> Terminal

@falmerbid hey so directly it did not work. I created a new environment and installed the required this. How do I launch this environment in Jupiter notebook. When I do run Jupyter notebook I get "Copy/paste this URL into your browser when you connect for the first time,
to login with a token:
http://(ip1 or ip2):8889/?token=c330b6dac949448f37b9238948420f9b958e1c7ecf263189

but when I go in my browser it says page not found, even when I just go to one of the ips

@bluesky314 you need to change the IP address in your URL with the URL address provided by Salamander.ai

you will find it in the “welcome to the dashboard page” under Links.

for example: http://:8889/?token=c330b6dac949448f37b9238948420f9b958e1c7ecf263189

Thanks, but salamder.ai has updated everything. Just start a new server and done!

That work for me :
conda update -c fastai fastai
You have to restart Jupyter after update.

1 Like

Not always in LINUX (I use Ubuntu 18) reinstalling Pytorch or Fastai solves the issue of the “name ‘untar_data’ is not defined”.
This because the last release of Pytorch requires the newest NVIDIA driver possible (for me ver. 390 was not enough, so I solved installing ver. 410). So the first step is to verify if your NVIDIA driver is updated or not.
Sometimes trying to renew the driver , you receive and error from NVIDIA installer: please remove the Nouveau Driver.
But also this assertion is false because for sure you have already installed an NVIDIA driver.
In this case my suggestion is to try to install the newest driver with the desktop utility ‘System & Updates’.

Has anyone been succesful at using untar_data to donwload data from a url? I have tested it on files that end on .tar.tgz, .tgz, and .gz and for all three I get the error “not a gzip file”.


I used this temp solution to unpack the file first. Pending a more elegant way.

1 Like

Got the same error, followed this “Colab | fast.ai course v3”. Any suggested solutions?