Unable to install Ubuntu

i was following Live Coding Session 1, so, wsl --install was able to install few stuff but when it reached at Ubuntu in stopped at at like 2.5%, it stayed there about 30 min and after really don’t any any idea what i should do, i reboot my machine and tried to install Ubuntu as separate distribution ( because now wsl was giving help argument)
with separate instillation it stopped at some percent (3.5) or something.
so in frustration i uninstalled everything install by going to control panel,
but something as wsl is still installed when i tried wsl --install -d Ubuntu then
Downloading: Ubuntu
An error occurred during installation. Distribution Name: ‘Ubuntu’ Error Code: 0x80072ee2
errror message came after showing downloading percentage.
what should i do?

In case its a poor network, maybe download the distribution first and install from local disk.
Start with “Downloading Distros” section here.

You can download via BitTorrent which is a non-sequential transfer protocol meaning the process can be resumed after an interruption. The official Ubuntu disk image can be found here.