Starlette and google cloud error

Hello everyone :slight_smile:

I’m working on a second part of the course and created a leaner that can now predict some bird classes !
That’s all super cool but when trying to create my website using starlette i get a weird error even tho starlette is installed (checked with pyp3 list) i cannot seem to import.

There is the error :

 from starlette.applications import Starlette
ModuleNotFoundError: No module named 'starlette'

I installed it locally the same way and everything worked. I don’t know if its linked to google cloud or what not. Do you guys have any idea ? Thanks !

Solution :
Got it to work by uninstalling the old starlette using =>

pip3 uninstal

and installed it using =>

python3 -m pip install starlette
python3 -m pip install uvicorn

Don’t really know the difference with pip3 install, but at least it now works :slight_smile:


did you try installing it through conda?
you can use:
conda install -c conda-forge starlette

1 Like

Not really but my solution works for now.
Thank you :slight_smile:

Thank you @TyLo. I had the similar situation and your solution worked for me.