Setup on Salamander


#16

can you use fastai v1 with jupyter notebook as well? or does it only work with jupyter lab?


#17

JupyterLab is just an IDE for working with notebooks, code and data. When you are using JupyterLab you would still be using your Jupyter notebooks in the usual way.


#18

Thanks Andrew, just tested the jupyter notebook option but in the courses directory inside fastai there were 0.7 courses so switched to jupyter lab

opened jupyter lab
selected ‘fastai’ which i understand is v1
imporeted lesson 1 from new course
and got error message when importing fastai:

from fastai import *
from fastai.vision import *
import fastai.vision.transform as foo 

---------------------------------------------------------------------------
ModuleNotFoundError                       Traceback (most recent call last)
<ipython-input-2-bb50de15a0f6> in <module>()
      1 from fastai import *
----> 2 from fastai.vision import *
      3 import fastai.vision.transform as foo

ModuleNotFoundError: No module named 'fastai.vision'

am i doing something wrong here? thanks for your help!


(Ashton Six) #19

@bluesky314 The K80 is a great option for the fastai course. You’ll probably want to ssh into your server to download data / weights (click “Setup Access Keys” & follow along)

@miwojc

both Jupyter Lab & Jupyter Notebook work well - they just look different is all. Jeremy will be teaching using Jupyter Notebook so if you’d like to use the same thing open “Preferences & Account Details”, then click “Switch to Jupyter Notebook”

If you selected the “fastai” kernel that should work fine. I’m updating the images today in preparation for Monday & will double-check the lesson1 notebook works. (if you can’t figure it out you may want to create a brand new Salamander server on Monday)


(Edward Hiscoke) #20

Thanks for a great service!
N00b question here: In the “Design Another Server” page it states “NB: Once launched, Salamander can’t install new software automatically”
How do I update fastai and pytorch to the latest version? I tried

conda update -c fastai fastai

And got

PackageNotInstalledError

I’m missing something here…


(Ashton Six) #21

@Edward conda updates on Salamander have been broken for the last 3 days. I’m working on a fix right now.

Once fixed, you’ll need to run “source activate fastai” before “conda update fastai” (no channel needed for updates). I also recommend creating a brand new Salamander server on Monday.


(Edward Hiscoke) #22

OK, will do!


#23

@ashtonsix How do I buy credits? does it just keep on taking 20$ amounts from my account? Also what does “Setup access key” do and how do I SSH into my laptop as you said? (I’m totally new to this)

Is there a running timer I can see how much time server has been running?

In order to completely stop my server do I have to just log out or click ‘destroy’? How do I stop my server to halt the time usage but access it again later?


(Alvaro) #24

@ashtonsix Thank you very much for providing this very easy to use setup.

I created a Salamander server 2 days ago. The versions I find when using the jupyter fastai launcher are torch 0.4.1 and fastai 1.0.5. From the Unofficial Setup thread (Local, AWS) we would expect to use PyTorch 1.xxx instead. Is that something you’re going to address also for servers that are newly built today? Please let us know when the new changes are ready, or if we should still wait a while. Your setup is so easy to use that it’s tempting to create a new server every once in a while just to check, instead of waiting for your updates.


#25

I am unable to run functions from the new v3 version of the course including untar_data and ImageDataBunch. @ashtonsix can you do something about this before the course starts?


(Ashton Six) #26

@aloy

Create a brand new server & you’ll have the latest software: pytorch-nightly (1.0.0) & fastai (1.0.11). Besides the tutorial, everything on Salamander is ready for class.

@bluesky314

Could you try creating a new server, make sure you’re using jupyter notebook (you can change this by opening “Preferences and Account Details”, then clicking “Switch to Jupyter Notebook”) & try again? & make sure the “fastai” kernel is selected (should be selected automatically for servers created after today)

Click “Setup Access Keys” & follow along, you’ll soon be able to ssh into your server.

To stop the server click “Stop Server”


(Alvaro) #27

@ashtonsix Thank you! After creating a brand new server it works great.

@bluesky314 Both untar_data and ImageDataBunch work in my new Salamander server.

Others may be interested in the versions of components, so this is what’s showing for me (I got a 1xK80 server):

python version  : 3.7.0
fastai version  : 1.0.11
torch version   : 1.0.0.dev20181020
nvidia driver   : 396.54
torch cuda ver  : 9.2.148
torch cuda is   : available
torch cudnn ver : 7104
torch cudnn is  : enabled

Please anyone let me know if it’s inappropriate to post these details and I’ll be happy to remove them.


(Kaushik Jaiswal) #28

@ashtonsix Hey ashton ! can we use amazon credits on salamander?


(Ashton Six) #29

@Kaushikjais Soon! I’m adding a way to add promotional credits to your account & it’ll be available either later today or tomorrow. rn my main focus is service reliability as some users have reported issues with servers getting stuck while starting / stopping


(Kaushik Jaiswal) #30

@ashtonsix Thank you ! Hope you will add it soon and yes i too faced this problem while starting and stopping the server on salamander.


(Aya Salama) #31

Hello @ashtonsix .my notebook is not connecting to the kernel successfully .keeps disconnecting and trying to reconnect. Please advise i urgently need to so some work


(Aya Salama) #32

Anyone else having salamander problems ,?


(Ashton Six) #33

@Aya You mean, you’re able to open Jupyter Notebook but once open it can disconnect & you never see any results? If so, that’s an issue with Jupyter Notebook itself rather than Salamander. It can be caused by bad network conditions.

From the Jupyter Notebook team:

Anything already running in the notebook will keep running, and the kernel it started for that will stay running - so it won’t lose your variables. However, any output produced while the notebook isn’t open in a browser tab is lost.

See this thread for more details. For now, the only thing I can think of would be trying a different wifi / network or maybe plugging yourself into ethernet.


(Aya Salama) #34

Hi @ashtonsix! Thanks for the feedback. I excluded the bas network option because YouTube was running fine .but you are probably Correct since it worked when i moved to another place. Thanks alot !


(vibhor sood) #35

@ashtonsix

Inside the notebook I tried :

!pip install fastai --upgrade
!conda install -c fastai fastai

But fastai is still not getting upgraded as its still showing me fastai version 1.0.11 instead of the latest 1.0.18?