Setup on Salamander


(Ashton Six) #1

Hi, I’m the creator of Salamander. Salamander is less than half AWS’ on-demand price; it comes with fastai 1.0.0, cuda & pytorch pre-installed; after signing up it takes less than a minute to create a server with everything you need for this course.

To get started visit Salamander & sign up:

Accept the cuDNN license and everything in our acknowledgements section; click “Launch Server”.

Wait a minute for your instance to start and click “Jupyter Lab”. Make sure to select the “fastai” kernel after opening a notebook. That’s it!

2

Before the course starts I’m hoping to make AWS credits usable on Salamander (you’ll be able to redeem 75% of their value) & make the links configurable, so for example, you could make “jupyter notebook” the default.

If you have any questions specific to using Salamander, either generally, or for this course I’m more than happy to help (reply here or email support@salamander.ai) :slight_smile:


Unofficial Setup thread (Local, AWS)
(Jesús Pérez) #2

Hello! I tried to run the lesson1.ipynb but get the following error:

are there previous steps? Already done conda env update without results.


(Jeremy Howard (Admin)) #3

That’s the old version of the course, which uses fastai 0.7.


(Jesús Pérez) #4

Yes, but what I mean is that in the Salamander machine the packages from bcolz are not loaded. In my paperspace machine the fastai image run without this issue :slight_smile:


(Jeremy Howard (Admin)) #5

Yes - but this topic and discussion is for the new upcoming course, which uses fastai v1. @ashtonsix states above that he’s installed fastai v1. So please don’t use this topic for discussing the previous version of the course.


(Masaki Kozuki) #6

I really appreciate such a easy to understand UI and useful service!

I think the nvidia driver version here 296 is wrong, maybe typo?


(Pankaj Mathur) #7

Wow, sounds great, if you can make “AWS credits usable on Salamander”, I am already avid user of Salamander, but if you can add option to use AWS credit, then it will be fantastic…


(sashank) #8

can you please let us know steps for getting fastai v1 version .


(Ashton Six) #9

@sashankpappu With Salamander, fastai 1.0 is available already (as “fastai”)

@jm0077 Salamander includes both fastai 1.0 & 0.7. You can run both old & new course material.

These are the available kernels:

kernel_1

After opening a notebook you can change your selected kernel with the selector in the top-right:

kernel_2

This thread is for supporting students using version 1.0, for any questions re fastai 0.7 please email support@salamander.ai or ask in the 0.7 support thread

@crcrpar nvidia-296 should be the version installed on Salamander, here’s the install script I used for the drivers:

sudo add-apt-repository -y ppa:graphics-drivers/ppa
sudo apt-get update
sudo aptitude install -yq nvidia-396
sudo apt-mark hold nvidia-396
sudo shutdown -r now

(Bart de Goede) #10

@ashtonsix your service is amazing. Thank you so much for this! :smiley:


(John Hartquist) #11

Hey @ashtonsix, just wanted to say thanks so much for your service. I’ve set up ML boxes on AWS, GCP, Paperspace, you name it, but this was hands down the easiest time I’ve had getting up and running with both PyTorch and Tensorflow with Tensorboard. I’ll definitely be recommending this to others…


#12

396 :slight_smile:


(Ashton Six) #13

@bartdegoede, @johnhartquist: thanks! It’s silly for students & scientists to repeat the same rituals thousands of times when it only takes one person to setup. I’m just amazed nobody from aws or gcp tried to make this stuff easier.


(sashank) #14

This is awesome !!! … thanks a lot @ashtonsix let me try it and update you my experiences ;


#15

Is

K80 GPU
4x vCPU
61GB RAM. !

enough for fast.ai? And will I be able to upload my own data? And download trained weights? @ashtonsix


#16

can you use fastai v1 with jupyter notebook as well? or does it only work with jupyter lab?


#17

JupyterLab is just an IDE for working with notebooks, code and data. When you are using JupyterLab you would still be using your Jupyter notebooks in the usual way.


#18

Thanks Andrew, just tested the jupyter notebook option but in the courses directory inside fastai there were 0.7 courses so switched to jupyter lab

opened jupyter lab
selected ‘fastai’ which i understand is v1
imporeted lesson 1 from new course
and got error message when importing fastai:

from fastai import *
from fastai.vision import *
import fastai.vision.transform as foo 

---------------------------------------------------------------------------
ModuleNotFoundError                       Traceback (most recent call last)
<ipython-input-2-bb50de15a0f6> in <module>()
      1 from fastai import *
----> 2 from fastai.vision import *
      3 import fastai.vision.transform as foo

ModuleNotFoundError: No module named 'fastai.vision'

am i doing something wrong here? thanks for your help!


(Ashton Six) #19

@bluesky314 The K80 is a great option for the fastai course. You’ll probably want to ssh into your server to download data / weights (click “Setup Access Keys” & follow along)

@miwojc

both Jupyter Lab & Jupyter Notebook work well - they just look different is all. Jeremy will be teaching using Jupyter Notebook so if you’d like to use the same thing open “Preferences & Account Details”, then click “Switch to Jupyter Notebook”

If you selected the “fastai” kernel that should work fine. I’m updating the images today in preparation for Monday & will double-check the lesson1 notebook works. (if you can’t figure it out you may want to create a brand new Salamander server on Monday)


(Edward Hiscoke) #20

Thanks for a great service!
N00b question here: In the “Design Another Server” page it states “NB: Once launched, Salamander can’t install new software automatically”
How do I update fastai and pytorch to the latest version? I tried

conda update -c fastai fastai

And got

PackageNotInstalledError

I’m missing something here…