Platform: Salamander ✅

Are you not able to use a g3s server, @mardybutt? I’ve been checking them each day and they’ve been available each time I’ve tried. To clarify, it’s at the bottom here (click the “server types” button to see it if it’s not currently shown):

image

You shouldn’t be getting charged if you destroyed your instance - send me a PM with your login name so I can check, if you think that’s happening.

Sadly the 1x M60/g3 has less RAM than the k80 and cost more per-hour.

Have you requested more k80’s from AWS support? And, if so, what is the status on getting more instances added to the Salamander platform account.

the shortage isn’t on Salamander’s side. AWS themselves have run out of k80 spot instances in North Virginia

ah, you are using spot instances, I understand the issue now, thanks for clarifying.

Any plans for Salamander to support additional regions or cloud platforms?

i don’t think so

I think I’m running into the same problem,

I’ve tried a couple of things, including deleting my old instance and creating a new one, but I think we’re pretty much stuck

Hi @ashtonsix @jeremy. I apologise, I am reposting this message since I might have posted it in a thread which hasn’t been active for 8 months now. I am taking my very first steps to get started on the ai course. I have been trying to launch the recommended server for sometime now to no avail. I might give paperspace a try next. Unfortunately, I had loaded a $100 credit on my salamander account. Since I was never able to start the server and thus did not use any compute or storage service, could my credit be refunded? Please let me know. I have uploaded a screenshot of dashboard which shows the details.

Yes but it’s a far faster GPU, which is generally what matters.

You just need to change to a different server type: Platform: Salamander ✅

@jeremy First of all, thanks for the course. :slight_smile: I am using Jupyter on Salamander (workstation graphics with g3s). Execution of even simple code takes long time
eg. data.show_batch(rows=3, figsize=(7,6)) takes around 5-10s.

Is there something I am doing fundamentally wrong in the server setup?

@sujithjose5 it takes a while for a newly launched server to “warm up”, since it has to transfer all its data from s3 the first time it is accessed. After you’ve trained a single epoch, all the data will have been transferred, and you should see things run fast again.

1 Like

Here’s an update I just sent all customers via email (although it’s currently stuck in Postmark’s queue, so might be a while before folks receive it):


I’m sure those of you that have been using Salamander recently have noticed that there’s been a severe shortage of the default type of server that we provide, the “Accelerated Computing” instance type. Unfortunately, our provider (Amazon Web Services) had a shortage of this server type, which we weren’t aware of until it started impacting Salamander customers.

We know that this has resulted in a lot of frustration and wasted time for many of you, as you have been unable to access your servers during this time. We are very sorry that this happened.

The good news is that there is now a faster and cheaper instance type available: the “g3s” instance, part of the “Workstation Graphics” selection. It’s what we’ve used for developing and teaching much of the fast.ai course. We’ve been checking this instance type every day, and it’s been available every time we’ve checked. It uses a GPU that’s about twice as fast as the “Accelerated Computing” instance, and is far cheaper (the Accelerated Computing instance is generally around 40% more expensive). The only downsides are that the g3s have less RAM and less GPU memory.

We have added the g3s option to everyone’s account. However we haven’t changed your current servers; to do so, click the “Modify” button next to any stopped server, and click the ‘g3s’ button, then click ‘Replace Server Hardware’.

In other news, we’ve disabled signups of new accounts for now, since we want to focus on serving existing customers effectively, rather than bringing on more customers.

1 Like

Hi everybody,

I’m having a problem with salamander again, my server starts, but Jupyter Notebook won’t. There might be something super basic that I’m missing, but I’m not able to figure it out…

After the ‘no server available’ issues described above, everything was running fine, using the Accelerated Computing v2. However, while running a notebook yesterday, I got an error message related to the memory use. I tried to restart my instance, but that didn’t work: the server starts, but Jupyter Notebooks won’t… A new tab in my browser opens, but it says ERR_CONNECTION_REFUSED.

Since then I

  • tried different browsers (chrome and edge)
  • tried different WiFi networks and providers
  • changed to different server hardware (e.g. g3s)
  • increased my storage space (from 75GB SSD to 150GB SSD)
  • switched to Jupyter Lab, but that’s also not working

After that, I made a new, second server (on the same salamander account) with the same specs. That one runs fine, and so is Jupyter Notebook. However, all my work and personal notebooks are on the first server. I have backups of my notebooks, but not of my saved models, so I would still like to regain access to my first server

I searched the fast.ai forum to see if anybody else had the same problems, but I couldn’t find anything. Maybe it has to do with the SSH keys? But that seems a bit weird to me, as I didn’t change anything and the second server is working fine…

Any advise would be highly appreciated…
Cheers,
Jeroen

connect to your first server via SSH and try starting Jupyter Notebook from there

I could not open my Jupyter with the message below:
“We started your server, but Jupyter isn’t running yet (it’s taking longer than usual)”

Does anybody know how to fix it?
I have waited more than a hour and still cannot start my Jupyter although the machine seems to be running.

You’ll have to ssh into it to figure out why jupyter isn’t starting.

@jeremy Thank you for your suggestion.
I am using PuTTY but could not get into it, because of “Network error: Connection timed out.”
I am very new with it, so perhaps miss something…
Following this instruciton, double checked IP and use port 22.


Anything else do I have to configure?

this can happen on Ubuntu when you try to SSH in within a couple minutes of your server starting. wait for a little bit and try again (if you waited over 15 minutes and still see this error then it’s something else and i don’t know how to help)

@ashtonsix Thank you so much for your advice!

Hi everyone,
In an attempt to create a language model for Ukrainian, I try to upload to my Salamander folder a wikipedia dump c.a. 1.5 GB volume. The upload process stops at 1.0 GB. Does it mean there exists some upload limit?