Platform: Salamander ✅

Does anyone know how to download a folder from Salamander to the local PC? I want to download my data folder. Thanks

To download a folder you can tar it then use scp (using the terminal).

Just want say that I also cannot import on Salamander. This is a new problem for me. It has worked in the past.

I also cannot generate keys to SSH in, and have had this problem with another (since deleted) instance. So I am going to lose the notebooks that I’ve created when I destroy this one. The “Generate Keys” just swirls for a while and then gives me this error.


Can anyone help me at least generate the keys before I destory the instance?

1 Like

I’ll see if I can figure out what’s going on there. Note however that you click new->terminal in Jupyter, which gives you a full shell - you can use that to put your ssh credentials in too.

1 Like

I have been unable to ssh either from the notebook to my local computer or from my computer to the notebook. I am new to ssh but it seems fairly straightforward. I have no problem generating the keys on either end.

the ssh-copy-id command is failing on both ends. I have tried using the IP address in the terminal (which I have read elsewhere in the forum is actually a local IP address) as well as the IP address in the dashboard. Is there some other address that I have to use?

I also cannot import on Salamander, re: Salamander import error, _C symbol

I tried restarting the server as well and it seems like it imports fine but then gives the error from the link

Hi there,

I recently got approved for AWS Educate and got promotional credit for a personal AWS account. I try to enter the code and I get the message “Invalid Promotion Code”. Did I create the wrong account type (I had a choice between AWS Account or AWS Educate Starter Account) or is this a bug?


Had the same issue (Invalid code) weeks ago, never figured it out…

I have a server that is stuck at ‘Offline - moving storage’. It has been for at least an hour and a half (likely longer, I’m not sure when my server auto-shutdown last night). It’s only 75gb SSD, of which I’ve used… I don’t know, I’d be surprised if I’ve used 30gb, but maybe?

I’d like to get access to that server, it unfortunately has some code and data that I need.

Also, as an aside, I just want to second Mark_F’s problem with generating SSH keys. I was unable to generate SSH keys or upload them. I got timeouts and the same ‘Network error: Unexpected token < in JSON at position 0’

1 Like

It’s stopped! I’m not sure if it’s a very-speedy admin, or if it just fixed itself within minutes of my posting, but either way: I’m good. Thanks.

Hi Jeremy, could you please say how to push ssh credentials using a terminal in Jupyter as you suggested before? I am having the same error “Network error: Unexpected token < in JSON at position 0”.

Second question: If I cannot setup an SSH connection with Salamander, how can I download my files from Salamander?
Third question: Is it thread an official support page of Salamander? and is here the appropriate place to ask about Salamander bugs and fixes?

You can paste ssh credentials directly into a jupyter terminal.

The easiest way to download files is often to use the ipython FileLink function.

There isn’t any support provided with Salamander, although I’m happy to answer questions here on the forum when I can.

1 Like

Does anyone know how to use the Redeem AWS Coupon?

the link on this page tell me to have a github education. When I have it, I apply for the aws education.

And now, I do not know what to do.

Can anybody help me?

Morning, all! I’m having an issue with Salamander - every time I launch my server, I get the following message while waiting for it to start up:

Waiting for Jupyter Notebook to start…
Traceback (most recent call last):
File “/home/ubuntu/anaconda3/bin/jupyter”, line 7, in
from jupyter_core.command import main
ModuleNotFoundError: No module named ‘jupyter_core’

Any ideas what I can do to resolve?

I say this with the greatest hesitation and the utmost respect for fastai and it’s mission, but Salamander is just not working, at least for me. I am now getting 500 Internal Server Error on every notebook, which was not happening a week ago. I have updated the course and done a gitpull. Every time I create a new server instance, it works for a while and then stops working. I have spent many hours now trying to get it to work, ssh in, etc.

I don’t know how much of this is just me (although I am not doing anything unique) and how much this affects other users, but I’m leaving this post in case there are other users with the same problem so that you know you are not alone.

Google Collab is a free option that has worked more consistently for me than Salamander. I also have an Azure instance set up that may be working but haven’t really used it yet. I have had a lot of trouble getting GCloud to work with the instructions given. I am spending so much time trying to get servers to work that I have not made much actual progress with the AI part.

Again, this is not to diminish the extraordinary effort of the fastai team. I have learned a lot and think the course is great. I just wish I wasn’t spending so much time trying to get a server to work.

@minh If you open a Jupyter Notebook and go to “File” you will see an option to download your notebook. This is by far the easiest way to do it and does not require ssh, which I never managed to get to work.

Added: Google Cloud is now working for me. A week ago I could not create the instance despite having an adequate GPU quota. So you can try that if Salamander is not working.


Thanks Mark. I have completely switched to AWS which is far more reliable and I find it easy to use too. As a student I received $150 AWS credit. It is more than enough to finish the deep learning course. I can’t believe a service like Salamander who is taking user money while providing no support whatsoever. Ridiculous!

I happen to be getting a 500 Server Error on Salamander while trying to open up notebooks too


I’m also having trouble accessing notebooks in Salamander, getting error 500 after a while. I tried destroying the old and creating a new server, and it worked, but after a while the same is happening. If I go to /lab instead of /tree I can open the notebooks but the kernel starts up.

Can someone help??

1 Like

Sorry to reply to my own post, but anyone have any ideas? If I destroy the server and recreate, I assume I lose my data, correct?

1 Like