Platform: GCP ✅


(EPHRAIM AYEMERE) #480

same here. looks like it’s no long available


(Rick N) #481

I’m just now moving to GCP after too much frustration with Salamander and then Gradient. But how do I apply the $300 credit? I don’t see that anywhere…

Oops now I think I see - it’s only a $50 credit for fastai - the $300 is the standard free trial? Can someone please clarify?


(Shashank Gupta) #482

Do we have to update our environment with the release of Pytorch Stable version or not?


#483

yep, $300 as a ‘welcome to GCP’


(Rick N) #484

Anybody know why I can’t change the gpu on my-fastai-instance in the GCP UI? Under Edit - Machine type - Customize I only have options for the P4:

image


(Nidhin) #485

Hi @ricknta
Which zone did you spin the VM in?
Different zones only have some GPUS.

To see the list of GPU availability
https://cloud.google.com/compute/docs/gpus/#gpus-list


(Rick N) #486

@npatta01 Ah you’re exactly right! I had seen that list but skipped over it figuring all gpus would be in us-west2-b - nope. Thanks


(EPHRAIM AYEMERE) #487

Hi @jeremy you mentioned in your fireside chat that we now have a sort of ‘plug n play’ access to fastai notebooks on GCP.

can you show me how-to in the forum pls? I spend quite tons of hours trying to access the notebook via gcp.


#488

I am getting following error today.

Starting VM instance “fast-ai-v3” failed. Error: Quota ‘GPUS_ALL_REGIONS’ exceeded. Limit: 0.0 globally.

Anyone successfully launched fast-ai image in GCP recently?


(SA) #489

same problem here. trying various methods.
Try this:


#490

Thanks and it worked


(SA) #491

good. worked for me too.


(Vishal Pani) #492

Getting this error in the first notebook (lesson1-pets), when running the help(untar_data) block
---------------------------------------------------------------------------
NameError Traceback (most recent call last)
in
----> 1 help(untar_data)

    NameError: name 'untar_data' is not defined

Thanks for the help!


(Scott H Hawley) #493

Just decided to try moving from my desktop to GCP. Following the FastAI GCP setup tutorial, it says nothing about quotas for GPU usage or the need to upgrade your account.

Hence I’m getting the same error,

"ERROR: (gcloud.compute.instances.create) Could not fetch resource:

  • Quota ‘GPUS_ALL_REGIONS’ exceeded. Limit: 0.0 globally."

…that others have mentioned above in this thread. I’m going to work on upgrading my account and changing my quota, but it’d be nice if that had been part of the instructions from the get-go.

Does anyone feel confident enough to edit the tutorial docs to include this crucial info?

EDIT: And mention that “Quota increase requests typically take two business days to process”


(Nikhil Utane) #494

It should work after upgrade to 1.0.38. I think there was some issue in .37


(Kofi Asiedu Brempong) #495

Hey guys, I wanted to know if there’s a way for me start training and have it continue training without being constantly connected to the server


(Wayne Nixalo) #496

I wonder if this is a new quiet change on Google’s part? A week or two ago I was using GCP (gpu) on a trial account no problem. Without warning I’m unable to start my instance today due to the same quota error you’re getting. Did you manage to fix it? I’m searching for a non-upgrade solution.


edit:

After more digging, looks like Google is indeed implementing changes preventing trial accounts from using GPUs. See this forum post referencing this google groups post. Apparently it’s not happening all at once since some people on trial accounts still have a gpu quota of 1.


(Scott H Hawley) #497

Thanks for asking. After I upgraded and requested an increase to the GPUS_ALL_REGIONS quota, I had to wait a day or two, so I stopped working on this until today when I saw your message.

Now that this process is complete, I’m able to complete the tutorial as given, and run the “lesson1-pets” Jupyter notebook.

I don’t know about any non-upgrade solution that would offer GPUs. I wasn’t even able to request the quote increase until I clicked “upgrade”. An alternative free option would be to use Google Colab. I’ve run the FastAI course lessons on that too with no problem.


(Dien Hoa TRUONG) #498

Hi all,

I have just started to do deep learning on GCP (Before I used my laptop). However I never work on pure terminal like this. There are many things I am not familiar yet.

  • How do we open an image ? I know that we can use jupyter notebook but I don’t want to open it every time I need to see an image
  • Same for a video.
  • How do we code by our own IDE, like VSCode ? I am not familiar with vim :smiley:
  • I find a short delay while typing in the terminal. Is it normal ?

I am very appreciated if someone can help me on these problems. Thank you so much in advance.


(Kofi Asiedu Brempong) #499

the delays in terminal is normal, I’ve also been facing it. It depends on the speed of your internet connection