Platform: GCP ✅


(Jesús Pérez) #416

what is the zone where you’d created the new instance?


(Akshay Bhardwaj) #418

I used us-west2-c instance.
You can choose other zones with the available GPUs from this list:
https://cloud.google.com/compute/docs/gpus/


(Jeetendra Kumar Sharma) #419

Getting following error while running the following command:

from fastai.widgets import *

ModuleNotFoundError: No module named ‘ipywidgets’

Note: After searching on the forum found this issue is there with colab but i am using google cloud.

I have also tried pip and conda installing the package still the same error.


(Nikhil Utane) #420

Having come from AWS, the thing I like about GCP is the fact that preemptible instances can be stopped and started back with data intact. Where as in AWS, the spot instance is automatically terminated. I know there are ways to mount your existing disk to the spot instance, but it always gave me some trouble. Also crucial is the assurance that my preemptible instance will not run for more than 24 hrs if I were to forget to turn it off.


(Iyappan Subramanian) #421

I can create new instance on us-west2-c.


(Sahil KARKHANIS) #422

Can you please help with changing the regions zones and using it. Would really appreciate it


(Paul M) #423

There are a lot of things I liked about GCP with fastai, even though stackoverflow is not as helpful as it was with AWS. In addition to what you mentioned, the default image was pretty good and the default machine for the fastai configuration was pretty powerful. It’s just a bit disappointing that I have a very hard time accessing the notebooks, sources, and data for the webapp that I deployed during the last couple of successful connections. I’d happily pay more (if that’s what GCP wants) to have the ability to login at any time and use a machine with the same file system. Is that even possible with GCP?


(Iyappan Subramanian) #424

I tried few things as suggested in this forum and stack overflow, but couldn’t successfully do it.

As Jeremy suggested in one of the forums, I’ve created a new instance.


#425

Which platform you created new instance? Can you also share me Jeremy post?
Last 3 days, I have no luck on launching or creating new instance in GCP. I am getting instance not available error


(Iyappan Subramanian) #426

I created new instance on GCP. I don’t remember the post. The point is, he mentioned something along the lines, if there is an ongoing issue, try to create a new instance and move on.

Did you try creating on us-west2-c ?


(Stephen Mak) #427

I did as you suggested, but it still didn’t work :frowning:


(Stephen Mak) #428

I’ve done everything you’ve suggested but still nothing :frowning:

Changed External IP address to static, created firewall rules to allow ports 8080/8081 as well


(Gabriel) #429

I had the same (similar) problem.

Try running Google Cloud SDK Shell as Administrator. That solved it for me.


#430

Yes. I did try with us-west2-c, but no luck.


(Iyappan Subramanian) #431

Here is the script that I use to create a new instance on us-west2-c. Hope this helps.

$ cat gcp-create-instance-2.sh
#!/bin/bash

export IMAGE_FAMILY=“pytorch-1-0-cu92-experimental” # or “pytorch-1-0-cpu-experimental” for non-GPU instances
export ZONE=“us-west2-c” # budget: “us-west1-b”
export INSTANCE_NAME=“my-fastai-instance-2”
export INSTANCE_TYPE=“n1-highmem-8” # budget: “n1-highmem-4”

gcloud compute instances create $INSTANCE_NAME
–zone=$ZONE
–image-family=$IMAGE_FAMILY
–image-project=deeplearning-platform-release
–maintenance-policy=TERMINATE
–accelerator=“type=nvidia-tesla-p4,count=1”
–machine-type=$INSTANCE_TYPE
–boot-disk-size=200GB
–metadata=“install-nvidia-driver=True”
–preemptible


(Stephen Mak) #433

Well… turns out I fixed the problem. Originally, I had been using the “Google Cloud Shell” that you can activate using the button in the top right corner when you start your instances (and it comes up at the bottom of the screen).

Turns out if I do it properly, and use the “Google Cloud SDK Shell”, i.e. the one you download onto your computer and install, that works like a charm following the tutorials. I guess lesson learnt is to follow the tutorials properly :stuck_out_tongue:

Thanks everyone for your help - really appreciate it :slight_smile:


#434

arunoda has GCP tool / script that seems to work well. I solved my connection issue by using one of two alternate web addresses: www.crestle.ai or colab.google.com. :wink: I don’t want to work harder on my setup than I do on the actual course material.


#435

Glad you figured it out b/c I’m fresh out of ideas.


#436

us-west2-c worked for me now. Thanks


(Prasanth) #437

No resources in us-west2-b? tesla-p4 gpu? I have been trying for hours! It worked till yesterday!