Paperspace setup help

(Sritanu Chakraborty) #246

Anyone looking for a referral code to get $10 off : BEA2077.

(Kevin) #247


has expired


please try LAUNCH5PX instead of the HNGPU5 needs to be added during the Machine Creation below the payment form

(Poul) #251

Dear Dillon,

Could you kindly approve my paperspace request? I have sent 3 requests and haven’t received any replies so far.

Kind Regard

(Mohmedzayd Mansuri) #252

Hi Jeremy I used the fast ai script to set up paperspace. But I am having issues in that script. It isn’t able to install Jupyter notebook. It shows the following error while installation

Traceback (most recent call last):
File “/home/paperspace/anaconda3/envs/fastai/bin/jupyter-notebook”, line 7, in
from notebook.notebookapp import main
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/notebook/”, line 45, in
File “/home/paperspace/anaconda3/envs/fastai/lib/python3.6/site-packages/zmq/eventloop/”, line 210, in install
assert (not ioloop.IOLoop.initialized()) or
AttributeError: type object ‘IOLoop’ has no attribute ‘initialized’

(Luis Enrique) #253

I had the same problem used this command: export PATH=~/anaconda3/bin:$PATH
and worked having access to jupyter

Now I am having problems with the notebook kernel dies when trying to run Python3
need help here

(Luis Enrique) #254

I created a new machine in Paperspace with the template they have.
I DID NOT “git pull” or “conda env update” and worked fine out of the box

When I ran the git pull and update in conda the environment did not work and was full of errors about paths, " "bcolz" package not found and dead kernels when running python3

(Mark) #256

try this, it worked for me


pip uninstall tornado
pip install tornado==4.5.3

(Benjamin Stevenson) #257

Thanks for solving that Mark!

I was having a similar problem but your tornado trick worked a treat.

(satish) #258

I have written my blog post about how to set up fast AI in paperspace.

Looking forward to your comments

(Luis Enrique) #259

Thank you, should you run this curl command on a “blank” machine or should it be run in a machine built with the ai.template from paperspace first?

I ran the curl command in a machine that already had some directories from environment and it sent errors about not finding some directories

(Merlin von Trott) #260


I’ve signed up to Paperspace last Friday.
As my request i only wrote “”, because i didn’t know about your problem with spammers.

I would love to get started with Paperspace to be able to continue with the course.
It would be awesome if you could approve my request.

(satish) #261

@leromerom , You are right . It works for the blank machine.

(Keri Multerer) #262

@leromerom, @satish860 I am having a hard time connecting to jupyter notebook as well. I launched a machine yesterday and have tried all of the suggestions listed above: ssh into the remote machine using both ssh options listed, pip uninstall tornado followed with pip install tornado==4.5.3. I even tried curl | bash from the medium post. I am attempting to launch a new machine to start fresh and waiting for approval for that one. At which point, I will NOT do a git pull or a conda update as suggested in an earlier post. I’m sure there is a magic formula that works, but really appreciate any advice…

(satish) #263

@keri the curl command has to be run on fresh machine and once the command is run you need to reboot the system .

Also if you can add a screenshot of the error it will useful

(Keri Multerer) #264

@satish860. Thanks for the advice. I finally got it working on an AWS instance following the reshamas instructions here: The only thing I didn’t different from the instructions was in part III: jupyter notebook --generate-config command didn’t generate the config file so I added it with nano config,added the line c.NotebookApp.ip = '*' to the file, and saved in fastai directory. I then launched the jupyter notebook with jupyter notebook and pasted in the url with token (leaving the localhost:8888 as is) into a new window and it worked! I’m including all of these details in case it’s useful for someone else.

(ecdrid) #265

It did generate the config file but it isn’t in the current directory…
It’s probably hidden under the home directory (atleast in Windows)

(pradla) #266

I am having errors importing libraries when running lesson1 script. Not sure if I need to change my paperspace set up. Does anyone have a solution?

I chose template to install. Then I updated the environment and did git pull. Then I am trying to run the lesson 1 code. The kernel is dieing when importing the libraries. Then my subsequent code throws errors.

(Arturs Polis) #267

I’d like to rant about paperspace approval process, appologies if this is a wrong thread for this!

Been thinking whether I should keep quiet about this and stay patient. Decided to speak up.

Paperspace process sure sounds broken. I submitted a GPU request one week ago and still haven’t heard back from them. Do they want my money or not? I would recommend not using them in future courses unless they get their act together. I don’t care if they are cheaper or not, if I have to waste time complaining about them I’d rather pay more to someone with good service. And yes, my purpose is to do this course and run machine learning experiments for my schoolwork.


Arturs Polis

(Reshama Shaikh) #268

tagging @dillon of Paperspace here