MultiFiT - Unsupported Operator Error on modified CLS-JA notebook

Hi everyone!

I am trying to build a classifier for Japanese and tried to leverage MultiFiT’s CLS-JA notebook.

Unfortunately, I have an error happening on the last line
results = [get_results(exp_path) for exp_path in cls_dataset.cache_path.glob("seed*")]

Which gives the below error:

TypeError                                 Traceback (most recent call last)
<ipython-input-55-c4396f59766d> in <module>()
----> 1 results = [get_results(exp_path) for exp_path in cls_dataset.cache_path.glob("seed*")]

2 frames
/usr/local/lib/python3.6/dist-packages/multifit/ in validate(self, data_cls, save_name, use_cache, save_preds, *splits)
    433         if len(splits) == 0:
    434             splits = [DatasetType.Test, DatasetType.Valid, DatasetType.Train]
--> 435         cache_file = (self.experiment_path / f'results{"" if save_name == CLS_BEST else "-" + save_name}.json')
    436         if use_cache and cache_file.exists():
    437             with"r") as fp:

TypeError: unsupported operand type(s) for /: 'NoneType' and 'str'

I am using Google Colab
The folder structure structure is as below:

I tried replacing the line with the below for example and it works, but obviously not with the loop…
results = [get_results(exp_path) for exp_path in cls_dataset.cache_path.glob("seed1")]

Any hint to solve that issue :sweat:

I am not sure if it was the source of the issue, but after changing the labels in my dataset from “str” to “int” and reloading my instance it worked.