Moving the fastai 0.7 folder - do not use pip for the MOOC!


(Jeremy Howard) #1

We’ve just launched fastai v1, which is a from-scratch rewrite: http://www.fast.ai/2018/10/02/fastai-ai/

I’ve moved the old fastai/ folder to old/fastai/. I’ve also updated the symlinks in all course folders. So everything should continue to work fine, if you’re using the conda environment and symlink approach recommended for the course. You won’t be able to use the pip version of fastai in the future, since that will be updated to v1, which isn’t compatible with the course - unless you pin your pip installed version to <1.

I’ve added this to the fastai readme FYI:

Note for course.fast.ai students

If you are using fastai for any course.fast.ai course, please do NOT install fastai from pip or conda using the instructions below; the instructions below are for fastai v1, but the courses use fastai 0.7. For the courses, you should simply conda env update , and the notebooks will work (there is a symlink to old/fastai/, which is fastai 0.7, in each course notebook directory).


No Module Named fastai.structured | Google Colab
Colaboratory and Fastai
(Jeremy Howard) #2

#3

Thank you Jeremy. I noticed pytorch version is 0.3. Can fastai run with pytorch 0.41 version?


#4

sorry. I did not notice in document that fastai is using pytorch 1.0.


(Sanyam Bhutani) #5

Edit: I was able to get it up on CUDA 9.0, I just installed the pytorch nightly build for CUDA 9 and everything worked nicely.


(Victor) #6

thanks Sr. i understand my problem


(reuven) #7

I used the conda env update method for installing fastai. Nonetheless I’m having problems running the below lines from the DL1 course:

from fastai.transforms import *
from fastai.conv_learner import *
from fastai.model import *
from fastai.dataset import *
from fastai.sgdr import *
from fastai.plots import *

I get an error

ModuleNotFoundError Traceback (most recent call last)
in ()
----> 1 from fastai.transforms import *
2 from fastai.conv_learner import *
3 from fastai.model import *
4 from fastai.dataset import *
5 from fastai.sgdr import *

ModuleNotFoundError: No module named ‘fastai.transforms’

And the same for all the other lines, if I run them individually. I notice that all of these are located in the fastai/old/fastai folder. What should I do?


(Won Seob Seo) #8

Thanks for the all the work!

Do we still have to run source activate fastai I think in my case, this solved errors I encountered while importing.


(Jeremy Howard) #9

Yes all the same steps as before are required.


(mmm wax) #11

Hi, I’m going to sound like a meddling manager who knows nothing (mostly true…I haven’t even started the class yet!) but is there a list somewhere of major changes between 0.7 and v1? I’m just trying to think ahead: once I finish the course, what will I need to be able to transition to v1, and use it in real world applications?


(Asif Imran) #12

Hi,

Would it be possible for someone (with github access) to tag and cut a release right before the v1.0 migration happened. I see a tag from May '18 but a lot has happened since then.

Not entirely sure but this commit seems like a reasonable stopping point

Many thanks in advance
A


(Jeremy Howard) #14

Great idea! Do you happen to know the exact commands to do that, so I don’t have to go figure it out?


(Marc Rostock) #15
git tag -a v0.7 59caaaa -m "Preserving 0.7 state of fastai library pre-v1.0 release"
git push --tags origin master

the release will then have to be done via the github webinterface (or REST based client):
https://help.github.com/articles/creating-releases/

This is the easiest way, but means that the date of that tag will be the current day (day of the commit) and NOT in the past. This can be manipulated though if that is important to somebody, see answer below the one chosen as correct:

Best,
Marc


(Jeremy Howard) #16

Many thanks. I called it 0.7.2. It seems to have created a release automatically: https://github.com/fastai/fastai/releases

It’s based on the commit before I commented out the jupyter stuff (since that’ll be fixed upstream): https://github.com/fastai/fastai/commit/e85667cfae2e6873b1bb026195b5d09a74dfcff9


(Jeremy Howard) #17

6 posts were merged into an existing topic: How to set up Windows 10 for fast.ai


(Stas Bekman) #18

Thank you, @marcmuc. That’s handy.

BTW, perhaps what you shared about needing to make a release is no longer needed. At least, once I pushed the tag, github immediately created a release. i.e. no extra steps was necessary.

and I combined a bunch of answers to make a one-liner solution that sets the tag date to when it actually happened, uses annotated tag and requires no git checkout :

tag="v0.1.3" commit="8f33a878" bash -c 'GIT_COMMITTER_DATE="$(git show --format=%aD $commit)" git tag -a $tag -m $tag $commit'
git push --tags origin master

where tag is set to the desired tag string, and commit to the commit hash.


(Marc Rostock) #19

awesome one-liner, goes to my copy/paste cheat sheet :wink:


(Jeremy Howard) #20

(Won Seob Seo) #21

Hi all! Now that fastai 1 is out, I wrote a short post on medium about using fastai 1 on Colab. Please check out if you are interested!


(Hoang Bao Tin) #22

can you post the link to the colab notebook. Thanks!