Module not found

I am running fastai lesson 1 2019 on my windows 10 laptop. I get a module not found error.

ModuleNotFoundError Traceback (most recent call last)
----> 1 from import *
2 from fastai.metrics import error_rate

ModuleNotFoundError: No module named ‘fastai’
How can I fix this???

How did you setup your machine? Did you setup conda or pip? Do you use virtualenv?

The error hints towards you not having installed the fastai library.

I originally used conda and followed instructions posted by Jeremy. That did work, however I cannot run the new course for 2019. The old course did run.

1 Like

I have the fastai library installed with the new course moved into course inside the fastai directory.

Hi, can you clarify if this is what you did to try to solve the problem?
I have the same error (“ModuleNotFoundError: No module named ‘fastai’”). It started 2 days ago after using fastai and all the notebooks without issues for several months.

Hi, i have the same error too!could you please clarify what I must do?

1 Like

I was not able to solve this issue!

1 Like

This is how I fixed it:

Did step 3 from

And create the instance with:

export IMAGE_FAMILY=“pytorch-latest-gpu”
export ZONE=“us-west2-c”
export INSTANCE_NAME=“my-fastai-instance2”
export INSTANCE_TYPE=“n1-highmem-8”
gcloud compute instances create $INSTANCE_NAME

And followed from there.

Same here. I got the " ModuleNotFoundError: No module named ‘fastai’" error.

Working in Windows 10, I was able to do it for the 2018 lesson but for not the 2019 one. I tried to recreate the enviorment in conda, but it didn’t help.