`make server` failing unable to authorise with docker registry

When I run the command make server to get the local dev server up and running I get the following error:

Building fastpages
Step 1/7 : FROM fastai/jekyll:2020-09-12
ERROR: Service 'fastpages' failed to build: Head https://registry-1.docker.io/v2/fastai/jekyll/manifests/2020-09-12: unauthorized: incorrect username or password
make: *** [Makefile:7: server] Error 1

I repeated this and got the same error after successfully logging into the registry with docker login https://registry-1.docker.io using my Docker Hub credentials.

Anyone have any idea what might be going on?

Do the following:

  1. Upgrade fastpages per the steps in the README, or if you want copy and paste https://github.com/fastai/fastpages/blob/master/_action_files/Dockerfile into the same file in your repo.

  2. run make build

  3. run make server

Thanks for the suggestions :slight_smile:

I updated the contents of the Dockerfile you mentioned but have the same issue, on both make build and make server commands:

$ make build
chmod -R u+rw .
chmod 777 Gemfile.lock
docker-compose stop || true; docker-compose rm || true;
No stopped containers
docker build --no-cache -t fastai/fastpages-jekyll -f _action_files/fastpages-jekyll.Dockerfile .
Sending build context to Docker daemon  20.43MB
Step 1/5 : FROM jekyll/jekyll:4.1.0
Head https://registry-1.docker.io/v2/jekyll/jekyll/manifests/4.1.0: unauthorized: incorrect username or password
make: *** [Makefile:18: build] Error 1

I checked and this other Dockerfile is up to date in my workspace.

You must be signed into to another registry or not able to see the public registry.

Can you do “docker pull jekyll/jekyll:4.1.0“?

If not this means something is wrong with your local authentication.