Lr_find error

I jumped right into IMDB course and trying to customize the notebook for my own dataset which is a simple dataframe instead of text files in some folders. I went through the Language model training part and get elegant accuracy but when I try to apply similar code to build a binary classifier, this error shows for lr_find(): “TypeError: ‘str’ object cannot be interpreted as an integer”

My code is like this after having a language model:

data_clas = (TextClasDataBunch.from_df(’’, rev_train_set, rev_val_set, text_cols=0, label_cols=1, vocab=review_lm.vocab))‘data_clas.pkl’)

data_clas = TextClasDataBunch.load(’’, ‘data_clas.pkl’, bs=40)

learn = text_classifier_learner(data_clas, ‘AWD_LSTM’, drop_mult=0.5)



(I’ve also tried updating my fastai package to version 1.0.58 but still not working…)
Please LMK any thoughts on it! Thanks!

Could you double check to see if you wrote or copied your code correctly? Just something I see that is confusing with the code:
learn = text_classifier_learner(data_clas, ‘AWD_LSTM’, drop_mult=0.5) --> AWD_LSTM isn’t a string, rather it’s a variable that is imported with all the fastai text stuff.