Jupyter Notebook wont work in Paperspace

Can someone help me with this error.
I’ve been trying to get jupyter notebook in my paperspace machine (fastai2 template Unbuntu 16.04) but I keep getting an error message in my browser whenever I copy the link.

“This site can’t be reached”

I hope someone can help me with this as i’ve been on this problem for more than 3 hours and its been extremely overwhelming. I’ve also tried so many methods but it still gives me the same error.

Would you recommend I just stop using paperspace and just use another platform like gcp?


Hi bhavi-san hope your having a wonderful day!

I suggest you try all the free ones, to find the one you like best and the one you find easiest to work with. I use Google Colab.

I tried most of them and this was the one I found easiest.

As they are free each one has some limitations.

On google colab for example it times out after 12 hours or disconnects if it doesn’t see some keyboard activity sometimes, and it doesn’t save anything automatically so you have to save your work contiuously.

I intend to build my own deep learning server once I have saved enough money for the GPU card.

Unfortunately I don’t use Paperspace so can’t help any more.

Cheers mrfabulous1

Unfortunately I cannot help you with your error, since I never experienced this one myself. But overall I can say that paperspace usually works quite well for me. I have been working with paperspace for a year now and only had some minor issues like a VM not shutting down properly (same can happen on GCP though). Try reaching out to their support, they respond rather quickly and hopefully can help you out.