instanceLimitExceeded for AWS

I’m really frustrated right now. Please, someone help. I’ve put hours in configuring AWS but now a success. Someone please jump in and help me

Is it a problem on end or it’s a problem on AWS’s end. I request for a limit from AWS following setup guide. I request LIMIT 1. And they sort of reached back. Asked me to add a credit card. But I’m still not sure if my limit has exceeded or not. Should I talk to AWS again?

❯ bash

An error occurred (InstanceLimitExceeded) when calling the RunInstances operation: You have requested more instances (1) than your current instance limit of 0 allows for the specified instance type. Please visit to request an adjustment to this limit.

An error occurred (MissingParameter) when calling the CreateTags operation: The request must contain the parameter resourceIdSet
Waiting for instance start...

Waiter InstanceRunning failed: Max attempts exceeded
usage: aws [options] <command> <subcommand> [<subcommand> ...] [parameters]
To see help text, you can run:

  aws help
  aws <command> help
  aws <command> <subcommand> help
aws: error: argument --instance-id: expected one argument

An error occurred (MissingParameter) when calling the RebootInstances operation: The request must contain the parameter InstancesSet

All done. Find all you need to connect in the fast-ai-commands.txt file and to remove the stack call
Connect to your instance: ssh -i /Users/abhimanyuaryan/.ssh/aws-key-fast-ai.pem ubuntu@None
bash  13.19s user 2.62s system 2% cpu 11:02.28 total

I assume you are trying to get p2/p3 instance. The problem: those are set to 0 in EC2 limits.
You’ll need to request limit increase. Go to AWS console, make sure you are in region you want. Then go to EC2 > Limits (on the left side). Find instance type and click “Request limit increase”.
In justification mention that you are doing machine learning and need access to GPU-enabled p2 instances. Once the ticket processed, you can go ahead and provision the new box.

I think I have my limit set to 1

Thanks they increased it to 1. I tried it. It works