Install Fast.Ai on Raspberry Pi 4, SpaCy issue

Is it possible to exclude SpaCy when installing fastai?

I have been stuck on it for the whole day and I do not need it, SpaCy is for NLP, but I need vision.

Could someone help please?

There is no separate package no. An option would be to build it yourself by cloning the repo and removing the text part + spacy dep.

thanks @sgugger I built it from source, failed as well.

Here is the details:

Could you please explain how to removing text part + spacy dep?


As I said, we have not done it, so I don’t know how to do it exactly apart from removing the modules you are not interested it (I’m talking about building fastai yourself, not spacy).

I saw your reply on the other thread. How did you solved the SpaCy issue on raspberry pi 4 ?

Anyone looking to work on Embedded devices - I would suggest getting a Nvidia Jetson Nano (99 + Charger + Wifi ) Instead of Raspberry Pi 4. Jetson Nano comes with 4 GB shared CPU + GPU RAM and Ubuntu 18.04. Jetson comes with OpenCV and pip install PyTorch and other libraries works in Jetson. I have not tried installing FastAI or SpaCy yet. Plan to do that later this week.

I was able to do a simple classifier / object detection training in it (with small batch sizes). Tons of examples in Youtube and Nvidia (all on PyTorch). They have a simple step to convert PyTorch to TensorRT (Nvidia Runtime engine) with FP16 (

Anyway, I don’t work for Nvidia. Just sharing my experience in using Jetson Nano and hopefully help avoid any frustration for someone looking to deploy PyTorch on the Edge.

1 Like

Get the wheels from
It worked on my Pi4 8GB aarch64 (64 bits) but you will find wheels for armv71 too.

Good luck!