Initial Setup on Paperspace - what worked for me

Here is what worked for me on initial setup on Paperspace, after the recent updates caused issues.

  1. For the most part, Reshma’s instructions worked, with 2 changes:
    https://github.com/reshamas/fastai_deeplearn_part1/blob/master/tools/paperspace.md

  2. When running conda env update, I got the following error:
    $ conda env update
    Using Anaconda API: https://api.anaconda.org
    Fetching package metadata …
    Solving package specifications: .
    Invalid requirement: ‘torchtext=0.2.3’
    = is not a valid operator. Did you mean == ?

CondaValueError: pip returned an error.

To resolve, I edited the environment.yml file by doing following
nano environment.yml (this opens the file for editing)
scrolling down to ‘torchtext=0.2.3’ and adding changing ‘=’ to ‘==’’
saving and exiting the file

  1. I then followed the new Jupyter Notebook instructions that Reshma had, including opening my local terminal. It kept not working until I changed the ‘8889’ in the notebook url to ‘8888’. Boom, that worked!

I really struggled to get through this, as much of this is not native. I am hopeful this helps even one person!

I also found the setup very difficult, even following the instructions; however, I expect these things to be difficult and require what can at times seem like an infinite regress of problem/solution/new-problem. I had two additional issues:

  1. I also run a local instance of Jupyter Lab. I modified my local Jupyter notebook to 8889 instead of 8888. That lets me run both a local and remote Jupyter server.

  2. I had initially set the paperspace VM to a 1 hour timeout; however, when you access the paperspace vm’s jupyter notebook server from your local machine, paperspace doesn’t see that interaction, so it thinks you haven’t been using the machine and shuts it down after 1 hour. Bumping this up to 8 hours was sufficient for most of my needs.

See this for info on how to change the port: https://stackoverflow.com/questions/40373330/change-jupyter-notebooks-localhost8888-default-server-with-other/40436673