I'm not getting anything uploaded to pypi

Hello,

I’m trying out the latest tutorial of nbdev_cards with nb_dev 2, and even after set up the .pipyrc file, it gets nothing uploaded. I don’t get a link in the terminal, neither can see anything uploaded on my pypi.org . This is the latest part of the terminal output:

...
copying nbdev_cards.egg-info/SOURCES.txt -> nbdev-cards-0.0.5/nbdev_cards.egg-info
copying nbdev_cards.egg-info/dependency_links.txt -> nbdev-cards-0.0.5/nbdev_cards.egg-info
copying nbdev_cards.egg-info/entry_points.txt -> nbdev-cards-0.0.5/nbdev_cards.egg-info
copying nbdev_cards.egg-info/not-zip-safe -> nbdev-cards-0.0.5/nbdev_cards.egg-info
copying nbdev_cards.egg-info/requires.txt -> nbdev-cards-0.0.5/nbdev_cards.egg-info
copying nbdev_cards.egg-info/top_level.txt -> nbdev-cards-0.0.5/nbdev_cards.egg-info
Writing nbdev-cards-0.0.5/setup.cfg
creating dist
Creating tar archive
removing 'nbdev-cards-0.0.5' (and everything under it)
running bdist_wheel
running build
running build_py
copying nbdev_cards/__init__.py -> build/lib/nbdev_cards
/home/ubuntu/miniconda3/envs/cuda116/lib/python3.9/site-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
  warnings.warn(
installing to build/bdist.linux-x86_64/wheel
running install
running install_lib
creating build/bdist.linux-x86_64/wheel
creating build/bdist.linux-x86_64/wheel/nbdev_cards
copying build/lib/nbdev_cards/card.py -> build/bdist.linux-x86_64/wheel/nbdev_cards
copying build/lib/nbdev_cards/deck.py -> build/bdist.linux-x86_64/wheel/nbdev_cards
copying build/lib/nbdev_cards/_modidx.py -> build/bdist.linux-x86_64/wheel/nbdev_cards
copying build/lib/nbdev_cards/__init__.py -> build/bdist.linux-x86_64/wheel/nbdev_cards
running install_egg_info
Copying nbdev_cards.egg-info to build/bdist.linux-x86_64/wheel/nbdev_cards-0.0.5-py3.9.egg-info
running install_scripts
adding license file "LICENSE" (matched pattern "LICEN[CS]E*")
creating build/bdist.linux-x86_64/wheel/nbdev_cards-0.0.5.dist-info/WHEEL
creating 'dist/nbdev_cards-0.0.5-py3-none-any.whl' and adding 'build/bdist.linux-x86_64/wheel' to it
adding 'nbdev_cards/__init__.py'
adding 'nbdev_cards/_modidx.py'
adding 'nbdev_cards/card.py'
adding 'nbdev_cards/deck.py'
adding 'nbdev_cards-0.0.5.dist-info/LICENSE'
adding 'nbdev_cards-0.0.5.dist-info/METADATA'
adding 'nbdev_cards-0.0.5.dist-info/WHEEL'
adding 'nbdev_cards-0.0.5.dist-info/entry_points.txt'
adding 'nbdev_cards-0.0.5.dist-info/top_level.txt'
adding 'nbdev_cards-0.0.5.dist-info/RECORD'
removing build/bdist.linux-x86_64/wheel
Uploading distributions to https://upload.pypi.org/legacy/
TypeError: expected string or bytes-like object
Old version: 0.0.5
New version: 0.0.6

How can I start debugging this?
thakn you!

You won’t be able to create that pypi project because I already have used that name.

Also, I don’t recommend you push a copy of this project to pypi since that’s unnecessary and confusing for folks using pip!

Thank you, Jeremy!

I suspected that was the reason, so I tried changing the following in settings.ini:

lib_name = nbdev-cards90210

However, the problem persisted with the same error. As per your recommendation, I won’t try pushing it to pypi again, but for the next time:

Which is the variable that defines the package name in pypi?

lib_name