Howto: installation on Windows

(Andrea de Luca) #223

They are just connection errors, either by your end or by the remote server.


i tried so many times, couldn’t solve it, i’m looking for other ways of installing it

(Andrea de Luca) #225

I was thinking you could download the repository, and then modify the installation script to read the repository locally. Try and send a PM to Jeremy about how to do it exactly.

(Ayush) #226

Tensorflow has started supporting these versions.

(Sam) #227

I have switched to ubuntu 16.04 with cuda 9.0 and cudnn 7.0
so i am good.


Hi everybody
I install fastai as @Jeremy described, but I have error when I run the first cell
“Matplotlib requires six>=1.10; you have %s” % six.version)

What is wrong?
with pip show Matplotlib I have 1.11

(Morgan Weiss) #229

I am using Windows 10 with an MSI-GeForce GTX 1070 8GB Video Card. I updated the drivers and began to the following steps. I downloaded Anaconda, Git, and proceeded to the following steps. The only part that seemed a bit off was when I did conda env update it gave me these recommendations:

Not sure what to do there but continuing. Once I got to step 8 on the del fastai part I get this:


Now lastly when I go into lesson1.ipynb, and I try to proceed but I get this error over and over again:

As an aside, I am a Mathematician by education and I am getting very interested in ML/DL so I just want to get my system set up to take my journey learning about ML/DL to the next level. If anyone can help I would really appreciate it.


to me, it looks like your fastai symlink is not created. you deleted the “bogus” one that works out of the box for unix, but do you see the error message when you try to create the link? You need to run that command as an administrator.

Somewhere in this forum is a link where symlinks can be created from the GUI using the RMB pop-up menu. That is how I set mine up.

(Morgan Weiss) #231

Actually, I was able to get it to work by doing the steps above as an administrator. Although, when I closed out and tried again making sure to activate fastai I launched jupyter and still got the same error that no module named ‘fastai’. I am not sure what the problem is now when I just got it to work.

(evana page) #232

the installation process of the windows is very easy. you get the proper ideas from hp support number. you will get the download link from this site which is very much useful for all the user.

(Kristian Rother) #233

Quick note: I have noticed that learning rate finder version 2 doesn’t work with the old pytorch ( as it crashed on (Tensor autograde issue).

After installing the latest version of PyTorch (0.4) via “conda install pytorch torchvision -c pytorch” I ran into an import error regarding some DLL. The following fixed it for me: “conda install mkl mkl_fft intel-openmp numpy”. Running fine now, with LRF2 :smiley:

(ecdrid) #234

You don’t have permissions, try using Administrator access and if you are on Win 10x64, you can use WSL to create the symlink for you…(just a simple command which can be easily Googled)

(ecdrid) #235

The easiest way to use fastai is to just clone it in a particular directory, and just point your jupyter notebooks to the parent directory of which fastai is a part of…
That way I can create all my notebooks at one place(the con side) but I can surely do git pull to use the bleeding edge version…

(prashant verma) #236

Trying to perform conda env update on local Windows machine with Nvidia GTX 1060, got this error:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Users\SONAVE~1\AppData\Local\Temp\pip-install-_exwb9r5\shapely\", line 80, in <module>
    from shapely._buildcfg import geos_version_string, geos_version, \
  File "C:\Users\SONAVE~1\AppData\Local\Temp\pip-install-_exwb9r5\shapely\shapely\", line 200, in <module>
    lgeos = CDLL("geos_c.dll")
  File "C:\Users\SonavexNUC3\Anaconda3\envs\fastai\lib\ctypes\", line 348, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: [WinError 126] The specified module could not be found

Command “python egg_info” failed with error code 1 in C:\Users\SONAVE~1 \AppData\Local\Temp\pip-install-_exwb9r5\shapely\

CondaValueError: pip returned an error

I know that issue is broken path “C:\Users\SONAVE~1\AppData\Local\Temp\pip-install-_exwb9r5\shapely\” (should be C:\Users\SonavexNUC3\AppData\Local\Temp\pip-install-_exwb9r5\shapely\ but don’t know where it is coming from. Any help is appreciated. Thanks!

(prashant verma) #237

Okay so I have the same issue on two Windows 10 machines now. Anyone else had this problem with conda env update?


No matter what I tried - I can’t complete the “conda update env” stage.
I’m getting an error message for “Failed building wheel for fiona” and “col_conv.h” file doesn’t exist
Help anyone??

(prashant verma) #239

@talz Yep, tried to manually install gdal, shapely, pyroj, rtree and Fiona, but conda env update stills gets stuck in one of these packages. Not sure what is missing. Seems like everyone else has it working.

(Luis Ortega) #240

I conda-installed geopandas to solve shapely. Stucked with Fiona.

(prashant verma) #241

@lucho Yes, stuck in same problem with Fiona installation. Any luck?

(Luis Ortega) #242

I did a bruteforce search of anything fiona installation related, including GDAL but no luck. I gave up. I think that once the issue is solved I’ll have to do a clean install of Anaconda and related stuff. I’ve blindly installed so much stuff I would be surprised if my setup never works satisfactorily.