Help with FastEC2

(Kyle Nesgood) #1

I realize I’m probably the only one having this problem, but I spent all weekend trying to troubleshoot and can’t figure it out. I’ve followed the steps from Jeremy’s article (https://www.fast.ai/2019/02/15/fastec2/) and keep getting:

Permission denied (publickey).

I have the .pem file on my machine - does it need to live somewhere specific (on Windows)? Any help would be appreciated!

1 Like

(Kyle Nesgood) #2

Update - using ssh works to get into the newly created box (when I specified where the .pem file was as part of the arguments). Is there a flag/option I missed in fastec2 to set this?

1 Like

(Phil Lynch) #3

Not sure if you’re still having this problem, but I ran into the same issue and figured it out:
fe2 connect base --keyfile ~/.ssh/mykey.pem

0 Likes