Gradient setup - missing "course-v4"

I tried following the instructions to set up Gradient, but when I do, I do not get the folder “course-v4”.

Should look like

Instead, I have “fastbook”, how do I tell if this is a newer or older version?

Everything else seems to follow on from the “course-v4” folder, so without it, I cannot proceed and I have no idea why it is different to the guide, I have tried to repeat the steps but it’s always the same.

1 Like

Hi Ross, I found the same problem
Did you find a solution?

Unfortunately not, I am stuck right at the start of the course and cannot progress

Have you tried to look into the fastbook folder? You will find all the notebooks as well as the clean versions in there.


In my case, the fastbook folder contains only the notebooks with the lesson corresponding to each chapter. All text and images, like in the book.
I can’t see the notebooks that we’re supposed to run.

The fastbook folder contains a “clean” folder, where you will find the notebooks that you want to run.
You should copy this folder to /storage in order to persist any changes that you make to these files.


That was very helpful. Many thanks!
Now, I can create a folder in /storage and save each notebook in the clean folder, but I’m wondering if there is a way to copy the whole folder to /storage first and work from there.


Yes, I had looked in the folder but I wasn’t even sure what I was looking for

You can start a terminal, as shown in the first Screenshot of this topic, and type:
mkdir /storage/mynotebooks
cp /fastbook/clean/*.ipynb /storage/mynotebooks/

Michael, you’re of great help. Many thanks!

I have a similar issue but I am not even getting fastbook folder.

I got paperspace file instead.

My notebook details are here:

Hi Sandy, did you choose the container when creating your notebook?
If yes, did you update the Fastai library?

I’ve noticed the version I have has some differences in the code examples compared with the 2020 video, for example the code in the book I have is “fastai” whereas in the video, it says “fastai2”
Did I somehow end up with an older version of the Notebook?

You can run: import fastai; fastai.version in your notebook to verify the version you’re running
For example, mine is ‘2.o.16’

I think this is because the library was renamed after the release of fastai version 2.0:

fastai became fastai1
fastai2 became fastai

You can always run !pip show fastai to see the current version of fastai or any package installed :slight_smile:

@Sandy9999 I had a similar problem (no fastbook or course-v4 folder) but I did have a README and License file. During the notebook setup I tried the option of connecting a Github repository as a workspace.

I created a new notebook without the Github connection and now I’m getting a fastbook folder correctly.

When I try to run that, it says has no such attribute, I was able to determine that I too am on 2.0.16 by upgrading via PIP.
I am curious now why I can’t call an attribute which you can on the same version

The call of fastai version is wrong
You are missing the double underscores, at the beginning and the end of __version__.

it is fastai.__version__, instead of. fastai.version


I was seeing Fastbook folder with updated container and it worked fine.
But facing a memory error issue while doing new install. Posting new issue separately.

how we install course v4 in jupyter notebook