GPU, local, Ubuntu APP in windows

Has anyone tried installing fastai v1 on the ubuntu 16.04 windows app? I cant seem to get it working properly. @jeremy do u use the windows app? I assume u do.

I haven’t tried - but why would you?

The stable pytorch v1 now runs on Windows. If you use the Ubuntu on Windows I doubt you will be able to access the GPU.

I had the same question too. But now that pytorch v1is on windows, everything works fine. Like @brismith mentioned, I wasn’t able to access my GPU by default.

As I know, CUDA is still not supported in WSL(Windows Subsystem for Linux). I suggest you guys go here and upvote this feature request,

@brismith @iyaja , the reason im asking is because i use multiprocessing intensively which requires global variables to be accessed by multiple class objects inside scripts. (similar to proc_all_mp). This is not working in Windowsn, on linux systems it works. I have a dual boot ubuntu, but its a pain switching between OSs if i want to do anything on the windows machine.

1 Like

For V3 of this course, I scrapped the Dual-boot and just left ubuntu to run on it. I moved the machine to another room and run it headless(without a monitor) anytime I am doing coursework. I simply remote into into it from windows to run the notebooks and class files. If you have a separate computer to do this, I would highly recommend it.


Similar to @FourMoBro, I’m running Ubuntu 18.04 headless. I remote-in from my notebooks using TeamViewer. Recommended. I also have a Windows 10 system which with the latest updates now runs lesson1-pets to completion. However, fastai on Windows 10 is not yet robust. lesson1-pets runs 5 times slower than Ubuntu. I believe this is due to pickle not being fully cured.