Fyi - Paperspace Jupyter notebooks not working...they are fixing now

Just to save people some time - currently (1/14/19, 12PM PST) the Jupyter notebook kernels are not working when using Gradient notebooks on PaperSpace.
I wasted a bunch of time trying to make a new one, restart the kernel, change the gradient config, etc. and ultimately gave up and emailed their support.
They just emailed back and said they are aware and working on it…
Anyway, for now, save yourself some frustration if you are trying to get your notebooks to work on Paperspace :slight_smile:


all fixed now.

1 Like

I also wasted a bunch of time to access jupyter notebook from paperspace account. but now i m still could not. Can you share with me your proplem when accessing jupyter notebook and how did you do to fix it?

Hi legalhacker - the issue I was hitting was there was no working kernel…so you would see a grey dot in the top right of the screen. And hovering over it would show “reconnecting to kernel”.
More importantly, if you tried to run a cell…nothing would execute. You would just hit shift enter and then it would go to the next cell, but nothing would fire (i.e. no print outs, response, etc).

It’s working for me now, though I keep getting pestered with this “413: ipynb save too large” or similar every minute or two…which is annoying as heck but at least the code cells are working.

Anyway, I didn’t do anything to fix the kernel issue…they had to fix that. If you are hitting the same error then might be worth emailing their support as they would need to fix rather than you.
Hope that helps!

Yes thanhk you so much for your detail answer,
for me, i do as instruction of reshamas, but there are 2 issues:

  1. I could not update conda/env (please see my image)
  2. i could not ssh (step 2.5 part IV) (please see my image)
    Therefore, i could not access jupyter notebook. I really be tired about it, and i would very appreciate if you can help me to fix it.

Hi Thao,
I would try again with this as it seems Paperspace has made a lot of changes the past few days. I no longer get the “error 413, save file too large” every few minutes for example. The flip side is they also blew away my datasets under /storage and the notebook I was working in is no longer even available…

Anyway, it seems they have done a big revamp and so hopefully the issues you hit here have been fixed now!

Best regards,