Fastprogress auto_update

Eeh… I’m sorry I’m flooding the forums this last days…

I’m not even sure I should be posting this because it’s an obvious bug. The new version of fastprogress broke fastai because of the auto_update parameter.

TypeError: __init__() got an unexpected keyword argument 'auto_update'

Please let me know if I should stop posting this kind of issues.

1 Like

I have same problem. and I try to run it again, another different err come out:
“empty file”.

1 Like

I experienced this as well. Interim solution is to use the previous version. :slight_smile:

Yeah I’m refactoring a few things in fastprogress so you shouldn’t use master until tomorrow night at the very least.

1 Like

Fixed that issue (which probably means you have to use master now since it’s a breaking change between fastprogress 0.1 and 0.2). I’ve tested a few things and it all seem to work but please report any bug with new fastprogress here so that I can fix them ASAP.


Hey there,

Sorry to be bumping this thread, but felt like it’d perhaps be better rather than creating a new one to unnecessarily clutter the board.

While attempting to run the first lesson from (on Gradient’s Jupyter Notebooks, over at /course-v3/nbs/dl1/lesson1-pets.ipynb), and whilst executing path = untar_data(URLs.PETS);, I get the same TypeError from OP’s message, which is:

TypeError: __init__() got an unexpected keyword argument 'auto_update'.

Is this still the same issue previously stated or is there a workaround?


It’s fixed in the new versions. Try updating your libraries by running:

!pip install -q git+ --upgrade
!pip install -q git+ --upgrade
!pip install -q git+ --upgrade

This has been fixed in fastai2 but not in fastai which the current course uses. You could either find the Python file which raises the error and apply the changes from this PR or wait for it to be merged and released


Oh, I forgot to fix it in fastai indeed. I will fix that this morning and make sure fastai depends on the latest fastprogress.

Edit: Just finished a release, so fastai v1.0.60 with fastprogress v0.2.1 shouldn’t have the issue anymore.


I’m using version 1.0.60, but still get the error about “unexpected keyword argument ‘auto_update’”, since the ProgressCallback class, in still references auto_update.

To fix this I just copied the class directly into my notebook, at the point I wanted to use it, and then got rid of the auto_update:

# self.pb = progress_bar(self.dl, parent=self.mbar, auto_update=False)
self.pb = progress_bar(self.dl, parent=self.mbar)

Obviously this could be copied back into to make it available to all notebooks that use this callback.


A PR with this would probably be useful :slight_smile:

Is it still not fixed? I get also the same error from the course code in the notebook 12c_ulmfit.ipynb.