Fastpages convert failed with 'dict' object has no attribute 'cell_type'

Here’s what I see. The notebook renders fine with the github web browser. Anyone know what could be happening here?

home0@Homes-MacBook-Pro blog % make convert
docker-compose up converter
Starting blog_converter_1 ... done
Attaching to blog_converter_1
converter_1  | Agent pid 7
converter_1  | === Running Locally: All assets expected to be in the directory /data ===
converter_1  | Converting: 2020-08-06-What is  ---to---
converter_1  | converting: _notebooks/2020-11-01-Explorations-Applying-Machine-Learning-to-Heavily-Processed-Tabular-Datasets-Anomaly-Detection.ipynb
converter_1  | 'dict' object has no attribute 'cell_type'
converter_1  | Conversion failed on the following:
converter_1  | 2020-11-01-Explorations-Applying-Machine-Learning-to-Heavily-Processed-Tabular-Datasets-Anomaly-Detection.ipynb
blog_converter_1 exited with code 0

if I call the directly, I get:

home0@Homes-MacBook-Pro blog % python _action_files/ 
converting: _notebooks/2020-11-01-Explorations-Applying-Machine-Learning-to-Heavily-Processed-Tabular-Datasets-Anomaly-Detection.ipynb
'list' object has no attribute 'map_filter'
Conversion failed on the following:                                                                                              


Something is wrong with this notebook maybe in the front matter or some markdown syntax that is breaking something. Its impossible to help you more based on the information you provided

Could it be possible that I fixed this problem by making sure that every code cell was labeled with the first line tags? (#collapse-show…etc.) I tried a bunch of stuff and I think that was what fixed it. Is there a way to get debug messages out of the converter, like running make server with a verbose flag? I didn’t find anything on that, and the exceptions were getting caught and not reproduced to the screen. Let me know if I can help with any of that.

You can try adding flags on your repo here

LMK how it goes

I am suddenly getting this now with nbdev @hamelsmu, looking into what’s up.

(My repo:

Huh. Kid you not the solution was:

pip uninstall nbdev
pip install nbdev
1 Like

LOL my problem went away so I did not take this up. If it appears again, and not solved yet, I will dive in. Sorry to not be of more help!

1 Like