[Fastpages] contents structure view broken while embedding folium map


I`ve uploaded several notebooks on my repos.
Everything shows fine on my website, except the one included folium map.
When I tried to show the map html through IPython.display.HTML


My contents shows like this,

I think that embedding html file in notebook breaks the contents structure view.

Fine one shows like this,

my notebook is here : link
and website is here : link

Anyone faced this problem?

Thanks in advance.

Can you just strip the problematic line out by removing the first line of https://github.com/goodboychan/chans_jupyter/blob/master/_notebooks/html/downtown_map.html

Or is there something else that is wrong?

Thanks for comment,

you mean “<!DOCTYPE html>”, right?
I tried, but it still shows that broken structure.

Strangely, when I show the debug console with chrome, I found that folium map generates div panel automatically with specific size. and it may enforce the change of whole structure in that notebook.

Actually, I’m newbie in HTML/CSS. so I don’t know what the problem is.

Thanks again.

What do you mean by broken structure?

Oh, I mean that markdown header.
Other posts render the header correctly, and maintain the content structure. but in that post,
markdown header doesn’t render well.

And one more question!

Is there any way to trust notebook file while converting from notebook to markdown?
I also faced the problem mentioned in here. And it seems like that disabling security in notebook will work.

I am not sure, I would try going through the troubleshooting guide in the README to see if you can diagnose the problem

I see. Thanks for your help!