[fastpages] A few hiccups

I am still experimenting with fastpages internally at my company and on a soon to come personal blog. I have noticed so far the following. Posting here in case there are obvious solutions I might have missed:

  1. Plotting graphviz graphs made with fastdot (which seems like a very good tools) spits me an ugly
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

right before the rendered graph. I am pretty sure there is a way to avoid this, but I am currently stuck

  1. Math rendering is not supported within info boxes (i.e. “Important”, “Note” and “Warning”). Adding a latex formula means that the box is closed and the formula appears right aferwards

  2. Given the text width of the rendered post is significantly smaller than what appears in normal notebooks, it’s easy to make plots and other output overflowing. Worst offender, for me, is the rendering of the tables. a simple df.head() with a dataframe that has more than 5 columns is larger than the text (at least on chrome) and there is no scrolling. Is there a simple way of prettifying the rendering of tables that I am missing?

  3. Minor gotcha: No adding an empty > (or possibly a full empty line) after a info box means that the paragraph following the box keeps the same font as the box, instead of the main one. This has nothing to do with fastpages, this is me being silly with markdown. I keep falling for it, though.


Can you link to an example notebook with sections for numbers one - four, which might help troubleshoot? Thanks

Not right now, but I will

Great, when you do please open an issue with the “bug” template on GitHub. I have a checklist there that helps me in triaging issues like this

1 Like

@miko Scroll Bars for tables were added via https://github.com/fastai/fastpages/pull/166

Preview of this:

Amazing, thanks.

1 Like


I was trying to figure out how to make tables scrollable on my fastpages blog and ran across this thread. I have not had scroll bars for any tables in my blog posts (note the table overflow causing horizontal scrolling on the entire page), nor do I see one in the example notebook post in the template repo. I’m wondering if maybe something broke? Or am I missing a setting to turn it on?

I appreciate all the work you put into FastPages — it’s a great platform.


Try upgrading fastpages. You may have to copy and paste the file .github/workflows/upgrade.yaml since GitHub made a breaking change recently to Actions