FastaiV1 MacOS Issues

Anyone facing issues with the v1 library on latest Mac OS. Conv learner is not working for me. Here is the error

Could you be a bit more specific? What is the error message? What installation instructions have you followed?

Also, on MacOS you will not be able to use a GPU as most new Macs have AMD GPUs.

I am not using GPUs ! I have installed it using pip, there wasn’t any issue during the installation. But when I tried to do learn.fit_one_cycle(). Error is something like data loader failed.

What is the exact error?

Please post the complete error log/image so that others might be able to help.
IMHO-without a GPU, its too long a wait to train a model.

1 Like

You are better off running the notebook on a cloud instance, since even if it works on your Mac its gonna take ages for your model to train, you will not be able to take advantage of working in an interactive environment that way. Try GCP since each new user gets $300 free credits.

Here is the Error–>

I just want understand the new library. I did last year’s version and know the concepts already, so the no point in spending on GPUs for the initial lessons.

I am able to run the first lesson notebook on my MBP Retina 13" on Mojave (although very slowly).

What version of fastai are you using?
I installed v1 using conda. Could you try installing using conda?

conda install -c pytorch pytorch-nightly-cpu
conda install -c fastai torchvision-nightly-cpu
conda install -c fastai fastai

I was able to resolve the error. It was due to pytorch dev version and had nothing to do with fastai

I used pip on a mac and it works nicely as well. Following the docs. PyPI Install for CPU for my PC as a start.

1 Like

Did this work for you?

I tried

conda install -c Pytorch pytorch-nightly-cup

but got

PackagesNotFoundError: The following packages are not available from current channels:
- pytorch-nightly-cpu

and sure enough, from here, Mac doesn’t seem to be supported. Implicitly from there, I am gathering that Mac is not even in the picture.