Fastai v2 chat

worked just fine last night

@amritv what version of ipywidgets is being used?

7.5.1, same version as that being used with v1 and no issues


1 Like

IPython is the same version too?

yes 5.5.0

1 Like

@amritv Sylvain suggests installing it via:

!pip install git+ —upgrade

If you have time can you check this? Otherwise I’ll try later today when I have access to a computer.

1 Like

I tried this, still getting the error =/

Opps, my bad. I first had to uninstall the previous version. Now it works =)

1 Like

Awesome!!! Glad to hear it! :slight_smile: thanks for checking for us :slight_smile: I’ve updated the Colab install directions in the v2 wiki to include this

1 Like

Did’nt work even with restart but worked with the following - YAY!

!pip install git+ --upgrade


We’ll be doing a new fastprogress release today to fix this BTW.


Release has been done and requirements in fastai v2 updated, so this should be solved now.


The effort to package separately the functionality we use to develop in notebooks is almost finished in the nbdev repo. One of the tests was to check if it worked well with the current fastai v2. It does, but starting from this commit, you’ll need that module to use show_doc or the exporting functionality.

We’ll now work on packaging so that the install is easy but if you want to work on master right now, you need to clone the repo and do pip install -e . inside (or install it from github).

(Edited with the latest installation instructions for nbdev)


Hi. Anyone has trouble importing fastai2? It was just yesterday that everythings worked fine for me, but today:

I’m running on Colab notebooks


I replied in your issue but cross-posting here. We moved things around yesterday and there was a stage where nothing was working. If the problem persists today, you need to remove any old install you add before re-installing (for me I had to go as far as removing the fastai2-egg file in my site-package directory).

Things are more stable now, the main change you will see is that fastai2 now uses nbdev to be built (thanks to Jeremy you can now pip install nbdev) and is named everywhere fastai2 (there is no more a local module for the notebooks).

1 Like

I don’t quite understand. Even starting a new colab notebook with no previously installed fastai2 at all (which ensures there’s no files that starts with ‘fastai2-egg’, right?), I’m still facing the problem with pip install git+

So can you please provide the clear steps to install fastai2? I had a look at readme but haven’t seen a change so far. Thank you.

Wait a sec, we’re changing repo for fastai2 anyway. Will update everything soon.


Do you have any plan for making the package installable with conda?

Not until it’s fully ready to be released, but when it’s time, it will be installed with conda install fastai.

So new repo is ready and here. Normally, you can follow the installation instructions there and it should work but I have only tested locally so please tell me if there is a problem.

For the github install:

pip install git+

For the local install:

pip install -e .

inside the cloned repo.

If you are just cloning this repo before contributing, don’t forget to run


@MichaelScofield I had an uncommited file in fastai_dev which I think was the reason for your problem (sorry about that).


Hi @sgugger,

I tried to install the new repo and got this error when do from fastai2.basics import *

I tried both pip install nbdev and pip install git+ but did not solve the issue.

Please have a look when you can. Thank you.

1 Like