Fastai not getting installed on the system

I am trying to install fastai on my system but not getting installed and throwing error after all the 734 mb download via pip download.

System info
Linux with no cuda

Can you post the full error message and walk us through how you installed it? Not much we can do without this :slight_smile:

Hey, Thanks for the reply.
Basically I first installed pytorch via link:
pip3 install torch==1.3.1+cpu torchvision==0.4.2+cpu -f

then just

pip3 install fastai

Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/pip/”, line 215, in main
status =, args)
File “/usr/lib/python3/dist-packages/pip/commands/”, line 353, in run
File “/usr/lib/python3/dist-packages/pip/”, line 749, in build
File “/usr/lib/python3/dist-packages/pip/req/”, line 380, in prepare_files
File “/usr/lib/python3/dist-packages/pip/req/”, line 620, in _prepare_file
session=self.session, hashes=hashes)
File “/usr/lib/python3/dist-packages/pip/”, line 821, in unpack_url
File “/usr/lib/python3/dist-packages/pip/”, line 659, in unpack_http_url
File “/usr/lib/python3/dist-packages/pip/”, line 882, in _download_http_url
_download_url(resp, link, content_file, hashes)
File “/usr/lib/python3/dist-packages/pip/”, line 603, in _download_url
File “/usr/lib/python3/dist-packages/pip/utils/”, line 46, in check_against_chunks
for chunk in chunks:
File “/usr/lib/python3/dist-packages/pip/”, line 571, in written_chunks
for chunk in chunks:
File “/usr/lib/python3/dist-packages/pip/utils/”, line 139, in iter
for x in it:
File “/usr/lib/python3/dist-packages/pip/”, line 560, in resp_read
File “/usr/share/python-wheels/urllib3-1.22-py2.py3-none-any.whl/urllib3/”, line 436, in stream
data =, decode_content=decode_content)
File “/usr/share/python-wheels/urllib3-1.22-py2.py3-none-any.whl/urllib3/”, line 384, in read
data =
File “/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/”, line 63, in read
File “/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/”, line 50, in _close
File “/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/”, line 275, in cache_response
self.serializer.dumps(request, response, body=body),
File “/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/”, line 55, in dumps
“body”: _b64_encode_bytes(body),
File “/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/”, line 12, in _b64_encode_bytes
return base64.b64encode(b).decode(“ascii”)
File “/usr/lib/python3.6/”, line 58, in b64encode
encoded = binascii.b2a_base64(s, newline=False)

@muellerzr Please help me to resolve the error

Have you tried either of these? (Found after a quick google search)

No not tried
I’ll just try and let you know

Hey does fastai gets installed on the system irrelevant of presence of CUDA as i don’t have it on the system and that is why i installed pytorch cpu on the system first. But still fastai is downloading that 734 mb file.

I would suggest doing a normal fastai install using conda. Even on a CPU only system, all should work fine.

Hey guys!
I am a novice to fastai
I have tried too much to use fastai in my pc and I face error after error relating to modules. Then I decided to use Colab server and follow the steps of However, I again faced an error: No module named ‘fastai.structured’. I am really disappointed about using fastai. I can see that exists in …/old/fastai. I don’t know why I see that error. I would be happy if someone could help me!

@Dark2Light you are using the older version of fastai (and I assume course Maybe?), which is depreciated. If you want to get structured you should be able to do from fastai.old.structured if not clone the repo and manually %cd to the old directory and you can.

@muellerzr Thanks for your quick reply. I am using the machine learning for coders course.

Yes. That course is quite old, so you’ll want to use the old version of fastai using how I described above.

@muellerzr Really appreciate it