Fast.ai setup on a gaming notebook - Runtime error


(Tom) #1

Hi!
I have a MSX i7 notebook with nVidia 1070 (8GB RAM) 32GB RAM 256 SSD on Ubuntu 18.1
I managed to run Lesson1 in cuda without any problems.
But, I failed at variant lessons lesson1-vgg and lesson1-rxt50
I get
RuntimeError: CUDA out of memory. Tried to allocate 9.00 MiB (GPU 0; 7.93 GiB total capacity; 7.08 GiB already allocated; 13.12 MiB free; 2.96 MiB cached)

Is it normal? Is my GPU too weak?
I rebooted the machine before retrying the lessons

Greetings,
Tom


(Tom) #2

I played around and of course, this is quite normal.
I watched the dogbreed lesson and I run the classification now.
Everything runs perfect with sz=64 and bs=56
Then, I changed sz to 224 and the GPU RAM immediately went 100%
So, I changed bs=16
I wonder if learning quality suffers, or only time.
It’s quite fascinating :slight_smile:


(Fabrizio) #3

Measuring the bs effect on the learning performances of common neural network architectures is an active research topic in the field of SGD methods. If you want to learn more a “soft” start could be this paper.

https://openreview.net/pdf?id=S1en0sRqKm

however, looking at the reviewers comments, do not expect any new insight inside.


(Tom) #4

Thanks!
So, basically,the conclusion is that there is a critical bs. Training is not faster.
I will look into that, at the other end of the stick :slight_smile: