ERROR uploading libraries on Gradient


I’m getting the following warning when running the notebooks on Gradient:

"ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

voila 0.2.4 requires nbconvert<7,>=6.0.0, but you'll have nbconvert 5.6.1 which is incompatible."

Not sure what I have to do about it…


Hi Paulo,
The new resolver introduced by pip is stricter and some packages that could be installed before Oct. 2020 may cause issues past this deadline.
Generally, you can check if pip is updated :

python -m pip install --upgrade pip

and then install your package :

pip install voila --use-feature=2020-resolver

I also got this warning message in Gradient for voila but it did work well and I could deploy the notebook without issue.
Hope it helps !


1 Like